I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


Views: 219246

Reply to This

Replies to This Discussion

More great news in the latest APM beta firmware, Terrain Following is here. I tested it and it works very well. What does this mean for MinimOSD-Extra? It means we can now know how high we are above the ground! Like a poor man's radio altimeter we can now see the AGL altitude. This is seen on the status page as tur_curalt. The terrain altitude is tur_alt.

Here is a message to you guys from Tridge:

It would be good if the OSD also displayed TERRAIN_REPORT.current_height, so OSD users know their terrain height. That value is available even if you are not following the terrain.


Cheers, Tridge

This applies to copters and planes.

But this only works if you have a telemetry link with a internet connected ground station? Off topic, but I was wondering what would happen if the internet drops on the ground station. Would that risk a crash?

It stores several square kilometers of data on the flash card (Pixhawk only). It updates continuously from the GCS, but even if the telemetry link is lost it would take a long time to fly beyond the data set.
More information here: http://diydrones.com/profiles/blogs/terrain-following-added-to-apm-...


I am using MinimOSD-Extra_Copter_Pre-release_2.4_r726 and having an issue of MinimOSD not reporting the correctly the altitude. The barometer and GPS are working fine and the true altitude is being recorded properly as it can be seen in the APM datalogs, but, for some reason, at certain point during the flight looks like the displayed altitude in MinimOSD is reset to zero. Check the following video:

MinimOSD Problem

Is anyone having any similar issue?


I have the same issue, I know this post is old but did you figure out a solution?


I connected the MinimOSD on Walkera X350PRO ( Devo-M controller based on  arducopter 3.2 )

the display on the monitor is perfect, they are displayed correctly: 

Mode of flight

but while remaining at zero 

Battery Voltage 
Number of Satellites hooked 

There is probably something wrong in the configuration someone who has successfully installed the MinimOSD could post the parameters with which it was able to get the data to me missing 

Thank you

Hi mbluca,

Make sure you follow ths instructions on the wiki and set the parameters right via mission planner:


If it doesn't work, scroll down the wiki page and try with the parameters in "Comment by Nicb...@gmail.comJun 8, 2014"

Hope that helps.



Hi Mathieu

The first configuration I had tried but nothing to do, in the meantime I accidentally reversed the polarity and ruined the MinimOSD.

Ordered a new MinimOSD, try again soon as it arrives.

Thank you

Sorry to read that.
Good luck with the new one :)

Hello Mathieu

I discovered the real problem, but I do not know how to fix it !

Mission Planner fails to update the parameters SR0_ on the EPROM, but if you write it seems riaggiorni return the initial ones, the strange thing is that the parameters instead SR1 update perfectly

I have seen that many users on the link that you provided me with the same problem


Hello mbluca,

This is weird... and probably extremely annoying ;)

I've read the comments you're referring.

I've no real knowledge on what the cause could be...

I guess you've tried to connect with the USB and alternatively with the telemetry (if you have it)?

If I stumble upon something interesting I'll forward it to you...

Good luck!

Hello Mathieu

I solved the problem now !!!

In practice:

if you are using - APM Planner SR0 parameters are not updated, so that the MinimOSD not working properly, and does not show the battery voltage

while using MissionPlanner (I used the latest version 1.3.9) the parameters SR0 update finally works perfectly and MinimOSD !!

This is the link from where to download MissionPlanner



© 2015   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service