guys im struggling to get my apm 2.5 quad in the air,

 

ive so fair diagnosed that the esc's wont arm and theres no output to them through the apm, have tested with other esc's and cli but nothing, ripping my hair out its been 4 days of testing and still nothing,

 

my auto calibration wont initialize and ive manually set each esc, used 2 different recivers and still nothing.

 

 

Views: 3321

Reply to This

Replies to This Discussion

Have you been through the Troubleshooting Guide here? That covers all the usual setup errors that can cause this.

yes i have thanks for the reply, i just tried booting the board back through usb too check the settings now more errrs, the board wont pop up in device mananger or open a port, the board still powers and i can connect via radio to MP even though its powered on USB, but i cant load usb, tried resetttign and nothing.

 

just not my day

Please contact tech support from the store you bought it from.

its an rc timer board so i doubt they will be in the office,

 

Just hit reset, reloaded the arudino drivers and BAM, go tthe apm loaded via usb,

 

Now just have the problem of esc's that dont arm, pheww.

also i tested the output and with the apm armed and throttle rising i go from 2.8v to 4.6 v steadily, so theres output voltage just no esc's

I wish you'd said it was a RCTimer board at the start. That's a clone and we don't support it.

Hello DS,

I was curious what program you would use with that USBasp? avrdude? winavr? studio 6?

I have confirmed that I do not have my bootloader and want to load one and then update my PPM hex to the latest one.

Thanks in advance for your input!

Tony

Ok, I'll download Studio 6 then as avrdude comes with that.

Thanks !

I'll report back whether I get it to work or not.

Hi Drone,

reading your posts, I'm guessing your are the (my) go to guy with technical questions.

here goes 

I had a ESC which gave 8.5V on the 5 V line....so I fried the APM2.5 board

There seems to be no communication on the USB port.

I exhanged the atmega32U3 and flashed it via ISP including bootloader

still no comms with USB. I can flash the 2560 via ISP ...but when updating via usb the green bar gets to the M of Marooned and then

communication error - no connection.

nothing is hot didnt see any magic smoke ...no craterered black tiles ...

checked diodes fuses etc...

do you have a hint where to look ...the schematic is not very clear on how the usb communication runs to the 2560 via 32u2 ...

don't spare any technical jibberish ...i can follow :-)

Thanks, Wilfred

Hi Drone,

thanks for the reply 

its not that difficult on the 8 bit front, just fire up your soldering iron :-D

There are 3 Carmens on this site can you tell me which Carmen is the one to ask the questions to?

Thanks, Wilfred

Post pictures of your wiring?

hey guys thanks for the help, im pleased to let you know i have a particular problem with my esc's i have to power them before my board to actually initialize them, i've adjusted all my PID's and have a successful quad, 

i appreciate your help, my next problem is my mission planner, everything works perfect except after a few flights my flight mode no longer goes into AUTO, every time it goes into AUTO it changes to loiter immeadiatley, i've recalibrated the radio and changed to swtiches instead of the petentiometer but nothing!,

any help would be greatly appreciated

And i'm definatley not discouraged this is my third quad and my first open source so to speak, its been a great effort to actually go from parts to a quad that sits stable at 50m for FPV flying, very very pleased. I just need to get this mission planner flight mode problem sorted ! cheers guys

yer its a 9x, its acurate on the radio calibration but jumping into loiter as soon as i it auto, although only just started doing this, 

any advice?

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service