APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Tags: 2.9.1.b, APM, APM1, APM2, Copter, Heli, Quad

Views: 92219

Reply to This

Replies to This Discussion

i can not find the Mission planner 1.2.41 in the downloads section, where is it?

I have noticed that the 2.9.1b has a "V frame" feature for quads (in the "Arducopter Level" screen). Is there any documentation about that? I have a TBS Discovery and perhaps the new feature is made for "spider shaped" frames like this? At the moment I use the X quad option but with special angles (like documented here and here).

All the best, Markus

Looks like the V frame is setup for a 45/135 arm angle quad, and it's giving more "control power" to the motors on the back since they're closer to the frame.  From AP_motorsquad.cpp.

// V frame set-up
add_motor(AP_MOTORS_MOT_1, 45, 0.8877, 1);
add_motor(AP_MOTORS_MOT_2, -135, 1.1123, 3);
add_motor(AP_MOTORS_MOT_3, -45, -0.8877, 4);
add_motor(AP_MOTORS_MOT_4, 135, -1.1123, 2);

As for 2.91b, it's working fine on my disco.  I'm still fighting old APM demos that are related to how stabilize mode works.  I think I'm just going to fly in acro all the time.

Switched my APM2.5 F450 from 2.90 to 2.91b yesterday.  So far, so good.  3 flights to date using 2.91b, without the loiter flyaway.  Need 3 or 4 more, to be sure loiter flyaways are gone from 2.91b, cause 2.90 loiter flyaways only showed up every other, or every third flight.

I noted that the first flight after installing 2.91b was dicey - lots of dancing up and down, until I got use to the new controls - after that first flight, 2.91b felt like home - just like 2.90. 

Yawing while loitering behaves differently in wind (badly) than without wind (perfectly). 

Without wind, yawing during loiter, at any rotational rate, the quad pretty much stays put. 

But with wind, yawing fast makes the quad drift - and not drift with the wind either.  The faster the yaw during loiter, the more the drifting.  But it comes back to the original loiter area, after the yawing is done.  Notable, with 2.91b, yawing during loiter didn't initiate a flyaway (just the drift, if there was wind) - it typically did with 2.90 in the wind.

So - yawing and wind unduly affects the quality of the 2.91b loiter - quite a bit.

Keeping in mind that my jury is still out regarding loiter flyaways - and bearing in mind my comments about wind and yawing during loiter - The following 2.91b features work fine:

  • stab mode - simple and normal
  • alt-hold mode - simple and normal
  • loiter mode (except as noted) - simple and normal
  • RTL - got to edge of 5m dia LZ in the wind, twice

Will continue monitoring loiter for flyaways.

Will add throttle failsafe and test.

That reminds me I found moving around in stabilize with wind (it was gusty, up to 20+ mph at times) made my copter very unstable at times.  I think I can tune more of it out, but it was clear variations in wind + control input was causing problems. 

I felt that lowering Stab_KP made it more stable in wind, but at times would greatly limit my control to move around in the wind, while raising stab_KP gave me more control but caused more problems.  I would normally adjust Rate_KP in the opposite direction of Stab_KP.  

The key issue I see is that  people will tune for no wind, and have some major problems with wind. For example, in a hover with no wind on my quad the following settings would hover the same.

  • Stab_KP = 3.5 and Rate_KP .120
  • Stab_KP = 5 and Rate_KP .100

That's just a hover but actually flying showed different problems when flying and with wind. 

Update:


Flying with little wind and everything is going great.  Had some issues using an older GPS but they all went away when I switched to the ublox.  Alt-hold is amazing.  No issues with waypoints.  Stabilize for any sustained forward flight is still awful so I'm still flying in acro mode 99% of the time.

Tim any news yet ? :-)

it's far too windy here to test 91b 

The problem is I'm so scared for the fly away that I am thinking of a kite thether ...do you think I need that?

Wilfred

i just tested 2.9.1b after a few mods:

1. installed 2.9.1b.

2. turned off compass auto learning.

3. turned off auro declination.

4. entered declination manually.

5. did the manual compass calibration.

one flight outside my house (at 10PM - its dark) - loiter most of the flight - so far no bad behaviours, but its early to say.

the more i think about it the more im leaning to to point that all of the crazy fly aways are due to the compass.

i wonder if setting compass offsets manually really does cure the compass problems.

Nope - too windy here as well.  I've disabled the compass_learn and compass_autodec functions, so I'm ready to give it a try. 

Not afraid of a flyaway when I'm actively expecting one - and when they happen I switch from loiter to either alt-hold or stabilize mode, and fly it back.  So, if I'm expecting one - say it's extra windy - I don't loiter down low right in front of me - I keep it up high, where I have the space to handle a flyaway.

6 flights to date on 2.91b, last 2 with compass_learn and compass_autodec off. And loiter has been behaving. Accurate without wind, and about a 24 ft circle in the wind. Yawing fast in wind during loiter causes temporary drift. RTL was within 20 ft of the launch point, most of the time. Liking this software so far. Well behaved. Maybe my loiter fly offs have ... flown away.

I can confirm this: No problems since I deactivated compass_learn and compass_autodec... Very nice.

I think 6 more good flights will put my mind at ease, concerning loiter flyaways. Use to get them every 2to 3 flights. Have 6 so far without. Need at least 12, I think, before I can say progress has been made. Takes some time to prove something is not happening any more.

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service