APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Tags: 2.9.1.b, APM, APM1, APM2, Copter, Heli, Quad

Views: 92259

Reply to This

Replies to This Discussion

Another thing, (although you probably know this already but just to make sure ;-), when you do the re-calibration, if you do have a GoPro, make sure to turn it on (FPV and record) as it does makes some difference on the calibrated offsets.  That said, further note that (works for me best) to re-calibrate, both declination and compass, auto-learn are turned on, then fly the quad on alt-hold (few 4-5m off the ground), clock wise stopping (pausing .5 sec @ stop) every 15 deg till 360 full circle then likewise, counter clockwise.. Then turned off the dec. and compass auto-lean and calibration is set (for life! ;-).

Daniel,

Thank you for the clarification and picture.
Looks quite impressive.
Will keep this in mind.

Cheers

Problem is that a ferrous material, can itself become magnetised. Park the copter for a long time in a static magnetic field, and the plate will be causing the problem, not stopping it. It can also be magnetised by physical deformation (knocking it etc..). The way that things that are magnetic will become magnetised, is why aircraft and ships have sometimes to be demagnetised, and their compasses have to be 'swung' to find the errors.

A _closed_ layer of a conductor, can form a Faraday shield, preventing any AC electrical field from passing.

Conductive shielding that is grounded, can be again used to effectively 'short out' AC fields, but won't stop a static field as you would get from (say) a battery wire.

The aircraft GPS units, used in 'full size' craft, have magnetic compasses in them, because GPS can't give a direction when stationary, or an accurate direction, till reasonable distances are moved. However most are quite smart, and calibrate themselves from the GPS bearing, once speed is above a few mph, and remember this.

Best Wishes

Spot on.

The only material you could use that would give magnetic shielding, is mu-metal. This though should be heat treated after cutting and bending.

Best Wishes

This may be a daft question, but why do you bother with a magnetic heading when using a gps or inertial, nav as they can navigate with true bearings and not unreliable magnetic ones?

GPS gives you the heading when the craft is in forward motion. When stationary, it won't know the heading.

And gyros drift in time and need to get corrected. It means they need reference which comes from the magnetic compass...

 

Interesting but I wonder if that is entirely true, as if you are navigating from lat/long to lat/long, then being stationary is irrelevant as the track is a simple calculation and the heading can be determined after a miniscule movement i.e. 1mm.

In the fullsize world we use GPS or inertial Nav, magnetic headings are an afterthought for ATC benefit really. After all the helis I have flown don't bother with magnetic as all autopilot calcs are done in true, even when in a stationary hover. They just use the true north (which doesn't change) as a reference not magnetic north as that changes all the time and is too easily affected by external influences.

I can definitely see that if the heli was totally stationary i.e. no change in lat/long at all then in theory it could start to rotate around its hover axis, but the inertial sensors should pick that up. And no heli is ever totally stationary in the hover!

Just a thought!

I think the simple answer would be "What we know/prove in theory cannot easily be implemented in our real world..."

I said "Stationary" but what is stationary? Being in stationary state is relative just like being in motion. According to the Relativity in fact, nothing is stationary...

In theory, yes if the craft moves even 1mm, then heading should easily be calculated. All you need is some distance between the two points to calculate the heading.  But is the satellite based positioning that accurate? Maybe if there would not be a clock error, if there wouldn't be adverse atmospheric effects and such. Then in Theory, that 1mm would be enough to pick up the heading. But it is not as simple in real world.

Seems you flew real helicopters. Funny at one point I did some research on fullsize heli autopilots and I had a hard time to find a heli that has autopilot system. All the heli pilots I talked to said helis don't use it much. The reason was the cost. After doing some research, I came up with some MD series helis had full autopilot system. But even then I couldn't find much info about it. Could you tell me what type of helicopter(s) you flew that had autopilot system?

And the real question is, how would those helis determine where the true north is if they are totally stationary (in Theory)? It would really not be possible without a starting reference. 

I don't think magnetic compasses are in use because they are more accurate. It is because they can be made work without the need of any external reference.

Yes I was a Captain for Bristow Helicopters flying IFR equipped North Sea heavy helicopters (Super Puma) and also have friends that fly SAR (Search and Rescue) helicopters with even better autopilots than we had. Ours were SFIM or Honeywell-Sperry full axis and supplied by Aerospatiale now known as Eurocopter. The Bell 212's used to a have a more rudimentary Bendix/Collins system. The SAR 212's had a much more fancy system.

When operating near the poles magnetic is totally useless so they don't use it. But of course the price tag was somewhat different, millions as opposed to a couple of hundred dollars which probably explains the accuracy!

I don't know to answer your question, maybe they didn't totally get a fix until we moved slightly. I just remember that they initialised while we were stationary. I doubt SFIM or Honeywell will tell you how they work, but you never know, it is always worth asking.

How do flight simulators work as they don't have magnetic inputs?

I know this thread is not about Mission Planner however none of this works without Mission Planner which runs very slowly on Windows 7 and Windows 8 unless Bluetooth is completely turned off which is kind of ridiculous fix. It has been reported in other threads. I am just wondering why that hasn't been fixed, does everyone run XP, is Mission planner ever tested on Windows 7 or Windows 8, Windows 7 is not exactly new.I tried all versions going back to 1.2.46 and they all do it

 

The symptoms are the drop down list for COM Port takes about 30 seconds to do 2 scans. Clicking on Connect, nothing happens for about 30 seconds. Status display most times a lot of readings are 0. Firmware updates fail in a communications error report. By the way that is running on an i7 that runs everything else like greased lightning except  Mission Planner. tested on many PCs and Laptops

There is another very easy solution that you failed to mention. It also is not quite as drastic as disabling bluetooth.

open computer manager, then device manager.

Expand ports, you will likely have two, possibly more com ports labeled 'standard serial over bluetooth link'.

Disable all of those that are listed, or if you actually use any of them, disable as many as possible.

The issue here is not mission planners fault persay, It simply see's a comm port and attempts to open it, windows takes it from there and attempts to connect the bluetooth comm port to whatever device caused it to be created. The delay you are getting is that connection timing out. once that happens, things move on...

You can obviously disable them then enable them when  you need them(if you need them) but personally, I haven't ever needed them as of yet...

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service