Frequently asked questions are about powering an APM2.5 or why the same does not work or why it has failed.

Here is a simplified schematic showing the major components of the 5V/Vcc circuit on the APM2.5

Target Audience: Readers who do not have Eagle or are confused about using it.

You Need: Basic electronic schematic reading ability

Note that I have separated the PWM Output section into the upper left corner with a heavy purple line that is bridged by the jumper JP1 on the APM2.5. This is to emphasize that diode D1 passes current through JP1 (and drops voltage). The remaining energy is then called 'Vcc'.  Everything outside the purple corner is Vcc.

This is why the USB will power the APM2.5 when connected to a computer/USB hub. Note the fuse on the APM2.5 side of the USB connector AND another fuse on the output of D1. Another change from APM2.0 is the D4 6.0V Zener diode. If an over voltage is applied to the board, D4 will crowbar what it can to protect devices.

As with APM2.0, any 5V source connected to any of the indicated Vcc/5V points outside the purple corner (with GND of course) will power the APM2.5.

Also of note is the 'Mystery Port'. This port takes 5VDC before D1 and the fuse and is called 'JP_VCC'. Other clues to the mystery are the lines to 'ADC 12' and 'ADC 13'. A mystery indeed!

Any errors in this drawing from editing are mine.

I hope this can be used as reference for solving problems.



27-FEB-2014 Eagle files are now located HERE


Views: 53715


Reply to This

Replies to This Discussion

Hi, could someone possibly help me with an error I'm getting or at least point me in the right direction as I'm kind of new here.

I have APM 2.6, gps, x8r, tinsy, on a tricopter (servo powered from separate UBEC)

Data logs report VCC fail,  4.6 v to 4.4 or less...

But when testing with a multimeter it reads the voltage as it should be, 4.85 or a bit higher...

This would appear to be a problem with something in the board that senses the voltage, is it ok to keep using the board or will it likely shut itself down if it thinks its not getting enough voltage?

I am new to electronics but I have soldered small things before, is it possible to replace the faulty voltage sensor, anywhere I can get more info on this?

Thanks very much for any advice

It probably means your UBEC voltage is sagging under load from the servo. I'm assuming you are powering the servo with the same UBEC?

The voltage sensor is actually built into the AVR chip, so its unlikely to be faulty without it not working at all.

thanks for reply but not sure we understand each other.

My APM 2.6 is powered from the Power Module that supplies 5.3v, servo is powered separately from a 5v UBEC.

Its the APM that is giving errors regarding low voltage, and the APM that I checked with a multimeter to be in the normal range.

I haven't actually checked the UBEC servo voltage, as I didn't think that was an issue.

Now I have also the main battery voltage sensor and current meter not working, I have 3 Power Modules I tested with but all give same results so the problem must lie elsewhere.

The Current reading is showing 10 amps even when nothing is happening, I try to calibrate but then it just gives the figure I type in permanently.

Same with LiPo Volt reading, it just reads whatever I last calibrate it to.

Now my tricopter wont start, presumably failing the preflight VCC test, although I'm not sure, because when I test it when connected to a computer it reads a higher VCC and does actually ARM then, so I dont see the error message, I am just assuming its coming from that.

Also it mostly does ARM when in the house but often not outside, maybe the low temperatures are affecting a sensor?

I dunno anyway, guess I have to buy a new APM2.6 but I would like to know whats going on if anyone has any advice. thanks.

Ok so I test with a new APM2.6

VCC now reads correct with all other setup the same as before. Must have been a fault on the board or chip?

Also the fault I had with Lipo volt reading was caused when I tried to calibrate it selected 'other' in the options. This time when I set it back to 3DR it worked mostly. Its reading may be a fraction off but not much.

Did you sort out the issue with the bad APM?

I just reread the above post and *10* amps is a lot of current with no motors turning!

The APM should only draw milliamps when simply powered up.

There are several components that, if failed, could make significant shorted supply conditions.


hi guys,

I'm using apm 2.5, hk esc with sbec, apm power module.

today while testing motor and servos, somehow the PM cable burnt to ashes. i suspect esc because motor was running at the time. PM was quite hot. Then i removed esc and use another cable to check PM and apm dosent power up.

but when i check with esc bec it works fine without problem.

i then checked output voltage from PM while connect to apm which was around 5.3, but it dosent power up.

apm works perfectly with usb and bec.

what might be the problem? brownout fuse or esc?

Which part burned?

There have been reports of the small cable from the PM to the APM burning, usually the ground/earth wire.

You should suspect F2 is open.

Take care with the wiring to follow the recommendations in the documentation.


Yeah that's right. After that I used a spare cable but didn't power up. I checked and pm gives out 5.4 v. Please note that I can power up apm using servo rail output.

There is a subtle difference between '5V' and Vcc in APM2.6.

5V is defined as the connection at JP3 ---> JP1(closed)---D1---F2--- then it becomes Vcc afterward.

The PM supplies JP_Vcc----JP1(open)---D1---F2--- same as above.

If JP1 is closed (jumper in) and a PM is used, the risk is potential voltage/current mismatch from the ESC/BEC and PM. They share a common ground(earth) and this is usually the failure point with the wire overheating and the insulation melting.

Another method is to simply remove the BEC output wire from the ESC. This way no mismatch can occur.

The condition does get your attention quickly. ;) :0


hello guys,
i'm currently using APM v2.6 for my quadcopter. i have set the flight mode to stabalize and i powered up the copter. i was also able to arm the board (and the motors started to spin). but later even for the full throttle the copter is not able to take off the ground. i kindly request someone on this forum to help me out to fix this issue. plzzzzzzzzzzzzzzzzz

thank you

Shashikumar - wrong spot for this question but, my initial opinion is your ESCs are not calibrated properly with APM.

The calibration can be tricky at times depending on your ESC and TX.

This does, of course, assume your motors are spinning in the correct direction for their assignments and that your propellers are on the correct motor and mounted in the correct up/down orientation on the motors.




Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2015   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service