I took my APM2/Y6 out for its maiden today. At first, it seemed ok, a little wobbly, but this is only with a few PID iterations. Something just doesn't feel right though. After some forward flight in stabilize mode, if I return the elevator to neutral, the copter will pitch back drastically instead of levelling and if I try to give it forward elevator to resume forward flight, it will barely pitch forward. I am giving it full forward elevator but the copter is still basically level. If there was more than  a 5mph headwind, there would be no coming back. 

I take it my stabilize gains are too high, but I don't understand why it attenuates my elevator input so drastically. 

I also set up my gear switch for RTL and the planner shows the correct mode when I switch, but nothing happens even after verifying I have a solid blue on the GPS.

Views: 357

Reply to This

Replies to This Discussion

Have you vibration insulated your board as instructed in the manual?

I used some  futaba foam servo tape (double stacked), similar to how I had my APM1 mounted. Is the APM2 more sensitive to vibes?

Yes, because it's lighter.

HI Chris

just off the back off that comment when will the APM 2 be released with 90 degree sideways headers ? its all good mounting the APM 2 like in the manual but in the last picture how must we get the servo wires plugged into the board ? there is no space . I think they should only be done in 90 sideways headers .

We'll be offering right-angle headers in the next batch, not this one. 

Chris, is there ant ETA for the next batch?

Cheers.

What I do is hold the copter on one hand (be safe) and pressure it up neutral using the throttle. If your hand is not smooth with vibration(s) across the throttle positions you may have a balancing or other mechanical problem. I test each arm individual for vibration.

i have been struggling with the same behaviour on my hexa with v2.3 - impossible to hold an angle against the wind and pronounced "rebound" after forward flight.  for me the key to getting it stable has been setting stab_d to zero and working on tuning the rate parameters.  when im happy with the rate loop i will go back and try to get stabilize values closer to the defaults again.

james

ok, somewhat comforting to know that i am not crazy. will try adjusting the stabilize PIDs as suggested, as well as better mounting. thanks!

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service