There is a preview on GIT right now. I flew a version of this

 

The PWM output has been set to 400hz (to counter the low pass filter in most Turnigy PWMs)

The DCM's Roll and Pitch gains were lowered to .03 (recommendation of Hein Hollander)

Mavlink has gotten a re-work for performance and memory savings.

 

Added a scaling factor to camera Roll And Pitch CAM_P_G, CAM_R_G in the params list.

Fixed some bad PID values for Alt hold that were giving folks trouble.

Exiting a WP for another is faster and more controlled now.

Added user hooks for those who want to execute their own code inline.

Increased loiter speed to center when the copter is flown > 400cm (now 800cm).

 

Loiter in action.

  Jason

Views: 29835

Reply to This

Replies to This Discussion

 

I think this is because the PWM frequency has been rised to 400 Hz and your ESCs don't like it.

 

You should be able to get the older mode adding this inside APM_Config.h and recompiling.

 

# define INSTANT_PWM    ENABLED

That worked! Thank you very much. I use the TURNIGY TRUST 45A SBEC Brushless Speed Controller, but it seems to fail with the new PWM setting.

 

I am going to test the .49, thank you all! :)

Today I make a flight with .49 and tuned the baro.

Now my copter flight very stable in Loiter.

Here are the logs:

The only things I have changed are the Loiter P to: 0.3 and the Throttle P to:0.36

 

On the pictures it´s only loiter modes. I have deselect the stabalized modes.

 

And here a picture for the hight:

I will now go on with automode

Attachments:

Second Log:

Attachments:

Just a question to all of you: I was using 2.0.46 before and then switched to 2.0.49, nothing else changed. In 46 I was able to see logs in the MissionPlanner log window, but with 49 it never shows any logs available. If I do 'dump 0', it will print a bunch of data that I can copy over to a textfile and display, but never does it show actual log files to download in the menu.

I'm not even sure it has to do with the swap to 49, I'm just trying to figure out what to do about it. Thanks!

Erase the logs and then try again. If need be, dump 0 should always work as you note. Just save the text as a .log file and you can analyze it with the MP as usual. 

Hey guys, everything is working great, loiter including except my Y6 is yawing very slowly still. Having set a yaw trim only helps slow the eventual yaw down unlike what I thought it was doing earlier. Any idea on how to fix this? My motors are perfectly straight, I wasnt getting yaw on .46 but loiter+althold wasnt working as good as it is now.

 

Could you check your radio ch4 input inside Mission planner raw sensor, radio window. And check if the value is right and consistent when you stick is in the center position. You should have the same value that you got during radio calibration for the central position.

 

 

Well I have redone my radio settings like 10 times with no luck so I am going to rule this one out.

 

Redo radio settings is not usefull. You should check that CH4 center position is consistent in the Mission planner raw sensor, radio window.

If it is not stable, then redoing the radio setting will not help.

 

Please report if you have consistent Ch4 center position. You should'nt see more than a couple microsecondes of jitter.

Tested 2.049 indoor today, made some PID tweaks, now copter is very stable, no oscillations at all. It must be the best firmware of all.

Here is a short video:

 

FInally got good enough weather to test 2.0.49 on my standard frame. Loiter is working really well after I tuned my Nav_loiter_P to 0.279. Oscillation is gone and it hovered very nicely in a 3 meter circle. It was the first time I felt safe doing a loiter in close quarters. I flew 6 packs checking things out and I did a 6 minute loiter at 15 meters in a small wind with excellent results. Baro hold is up or down 4 or 5 meters, but loiter was very good and I was more relaxed on the sticks then ever.  Awesome. 

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service