Version 2.4 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area.  Although not as big a change as the 2.3 release, it still includes a respectable number of enhancements and bug fixes.




Bug fixes:


The default PIDs are optimized for a 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props, start by turning down Rate Roll P in 25% steps.


Thanks go to the numerous contributors including users and their detailed bug reports, developers and testers.  Hopefully all together this will add up to a nice smooth release!


As per usual, please post your comments, issues in this discussion.  For enhancement requests for future versions, feel free to add them to the issues list.  Note:  you can "star" an issue to receive emails when someone comments on the item.  On the dev side it helps us because we can get an idea as to which feature requests are the most popular by sorting by the number of people how have starred each issue.

Views: 63386

Reply to This

Replies to This Discussion

What's your THR_RATE_P?

default .350

Try .450, that helped me

Ill give it a go, My hexa is hunting without touching the throttle even if I do get it into a hover, Its almost like its on alt hold but it isnt

Jason, I believe you have a lot of power for the default PIDs. I'm on a quad with 2218 motors 30amp esc 930kv and I had to lower THR_RATE_P to 0.225, but this setting will affect you only on auto modes if I'm correct. Your problem must be with RATE and STAB P terms. Try to lower RATE_P to 0.070 and STAB P to 3.000. The best thing, if you can, would be to use ch6 (in air tuning) to tune this settings. Start by tunning RATE P wich is the most important, give min and max tunning values 50 to 150 (that will translate to 0.05 to 0.150) start from the lower and increase it slowly, when you feel oscilations it means it's too high, lower it to a confortable value. Put STAB and RATE I and D terms at 0 before you do this, since first you want it to fly reasonably stable, then, the other params can be tunned properlly.


In air CH6 tuning setting not working at this time;

Graham yes is true, i open a new discussion in the dev list about this.
Have you tried the alpha version I sent you?

No sorry, did not get it.

Thanks Rui, Ive tweaked it down using in air tuning running about .080 on my RATE_P, going the other way makes it more lively(I usually tune my PID's via the strap to the chair method)

Once Im sitting in a hover it will drop down randomly, I then have to counter with throttle, its never done this before its dropping up and down, the motors are running up and down

I just cant seem to sit in a hover at any height as its surging up and down, Im sure it has something todo with new code as ive had a super stable hexa in the past

Maybe it's clear already but the THR_RATE_P is only used for alt hold.  It isn't used at all in Stabilize mode.

What effect would THR_ALT_P have?

Hi Graham.

THR_ALT_P is the ammount of throttle used to maintain altitude in alt hold (and modes that use alt hold, like loiter). If its too high, you will start to notice up and down oscilations untill eventually it will hit the ground, that's because too much throttle is beeing used, causing too much compensation, if you use too low, it will have difficult on keeping the alt too, so you you better start with the default and then tune it (using ch6 preference) untill you achieve a reasonable alt hold. Don't forget if you're using the barometer only, 1 - 2mts error would be normal (with APM1, since the baro of APM2 has a higher resolution that will allow you to maitain a very low error of 20 / 30 cms I believe).


© 2015   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service