Version 2.5 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Enhancements:

  1. The first ArduCopter code release optimized for the APM 2.  Leans and drift should be much reduced or even eliminated for most users.  This was accomplished through a number of core improvements to the DCM implementation by Tridge like this one and this one.
  2. Loiter and waypoint following should be improved due to a D term bug fix, some tuning and the improved DCM performance mentioned above.
  3. On start-up, the yaw heading is updated with first successful mag read (so you should no longer see the slow rotation from north to your actual heading).
  4. Increased output rate to ESCs to 490hz.  This update rate is also user selectable using the new RC_SPEED parameter.
  5. hexa copter stability patch bug fix (should resolve slight flattening when pitching forward and accelerating very rapidly).
  6. improved baro filtering
  7. fix to dataflash logging of Mag heading
  8. addition of H1 swash plate type and bug fix for proactive yaw compensation for collective pitch changes for TradHelis.

 

Tuning:

The default PIDs are optimized for a 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props, start by turning down Rate Roll P in 25% steps.

While some testers have reported very good flights with the default PIDs, some have reported that this release is a little "sharper" due to the DCM improvements and have found they needed to:

     reduce stabilize P by 10% (i.e. 4.5 -> 4.2)

     reduce stabilize D by 30% (i.e. 0.15 -> 0.10)

     increase rate D from 0 to 0.001

Tuning loiter can be tricky.  Refer to the discussions which will appear below for more community feedback on what parameters work best.

 

Please post your feedback in this discussion.  For enhancement requests  and bug report, please add them to the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.5 but tell us anyway!).

 

Thanks for this release go to the developers (both in the core team but also those who have provided bug fixes through the issues list) and also the community members who participated in the previous release thread and provided some great detailed information in the form of issue reports and logs which allowed us to nail some bugs!

 

Tags: ACM, APM1, APM2, Heli, Quad

Views: 127112

Reply to This

Replies to This Discussion

Hi Tim, read the first page of this thread or better still, start here: http://www.diydrones.com/xn/detail/705844:Comment:809873 - known bug with fix - increase THROTTLE_TRIM to 450. V2.5.2 has it fixed, available here: http://code.google.com/p/arducopter/downloads/list

Hi Tim, please can you put here your log/tlog about this issue?
During hundreds of test flights we have ever encountered a similar problemand from what I read no one has ever had such a problem, only an abnormal loss or gain of altitude with APM1, I found this problem today, and Randy has already solved, but all the motors shut off completely when engage loiter is quite strange.
Without your log is very difficult to reproduce the problem, and any video that I can not help us at all.
If the problem is related to the know "throttle_trim" issue (solved in 2.5.2) you could save your quad simply by returning to Stabilize.
We testers are always ready for any eventuality, his finger ready to activate Acro mode if elapse problems, unfortunately the version in the planner has some major bugs have been resolved, I hope Randy makes available the version 2.5.3 that we have improved today with our cross tests.

Marco -- thanks for your reply. How do I get the .tlog file off the board when connected over USB? I was not able to see the board as a drive in windows 'my computer' and can't find an option in MP. Sorry for this basic question... Also, here is a video that shows the behavior which may be helpful. 

Ok, i think this is a throttle_trim issue, i'm sorry.
Now, download the log is easy:

- delete all files inside "logs" directory (a subdirectory of the planner dir)
- connect you APM2 with USB to your pc
- open the planner and select the comm port and the baud rate but don't click connect!
- go to "TERMINAL" section, when you see on the screen some characters hit "ENTER" key for 3 times
- when you read "ArduCopter 2.5.0 ]" (is the prompt) click to "Log Download"
- If you're not sure what is "the log with the crash" download them all (end up in the "logs" folder inside that the planner)

Compress all files and upload here... thanks! :-)

After this event would not recommend flying with version 2.5.0 in the planner if one is not able to handle emergencies, rather use v2.5.2 in the download area.

Here is the log... sorry, I was not looking in the right place.

Attachments:

No Tim, wrong tlog, i see "Acro mode" and motors always disarmed (you fly in "Acro"????).
Try first to play the tlog to understand what is the right one! :-)
Inside "Flight Data", "Telemetry Logs", "Load Log" and then "Play".
Another way to tell is to look at what might be the time and date of the file.

Marco -- I looked at all my logs, I zipped them all up and attached them here. I don't see any log that has any meaningful data in it. I had a 3D GPS fix when I flew today, fyi.

Attachments:

I have acro mode as the first option on my 3-postion switch: acro / stabilize / loiter.

I normally fly KK boards, so I wanted to try acro in comparison. I did not fly in acro today though.

Ok... I watched all your tlog of today but no one sees a flight.
You must download all the log with method that I described... al your Telemetry Log are unusable.
The Acro mode of ArduCopter is very different from that of KK, I suggest you fly to Stabilize.

Marco -- I think I finally downloaded the logs properly. I isolated the log that I think has today's flight in it given the Google Earth kmz file I was looking at. Let me know if this log works better to see what happened.

Attachments:

Tim,

     I've looked at your logs and it's definitely the throttle trim issue.  Attached is a graph showing your altitude (green), the throttle output to the engines (red) and your manual throttle (blue - mostly hidden under the red line).

     You switch into loiter at 1761 and you can see the output to your motors immediately drops from 500 (which is apparently what you need) to 350 (the old default throttle_trim value).

     The latest code (now in the mission planner) properly captures the manual throttle and uses it as the base for the altitude hold.

     Very sorry to hear about (and watch) your crash.

Randy -- thanks for looking into this (and thanks Marco). I so wish I would have had another day so that MissionPlanner would have updated my board to 2.5.3. Not sure you know, but my company fpvmanuals.com makes multi-rotor kits like our popular Pro Tricopter Delrin Kit. Anyway, thanks for fixing the underlying issue.

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service