ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Views: 377402

Reply to This

Replies to This Discussion

So with your rig behaving in an unexpected manner you decided to deliberately fly it that close to your wife and child
?

Hi Reuben,

To be honest, I have not seen any difference after adding the code to enable the temp compensation. If I had the time I would do some testing with a hair dryer and super cold spray to try and see the effect of temp change with and without the compensation enabled. If you have done it before and are comfortable making changes to the code then by all means do so but I wouldn't go to the trouble if you have not done it before. I use a custom version of the code anyway so am already committed to re-adding my changes every time a new update comes out (not too big a job with the right comparison/merge tools such as 'Win Merge')

Hi James 

Thanks for the reply ..so I guess its best to just connect it the same as the one 3dr sell ..and leave out temp code changes until there has been more RnD into its benifits or its included into the Later Firmware ....

Maybe Randy could chirp in here and advise whether this is being considered.

Regards Reuben

Surely if you own and fly a multi-copter, you can determine the thrust direction of a prop?!

Randy,

Quick question: my Quad descends almost exactly at the set speeds. However, my Octo simply does not want to go down. It will go down, but as a snail on a threadmill going backwards. I've tried a variety of settings: Throttle Accel, Throttle Rate P & D. Do not know what it is. Alt-hold is just fine. 

I admit that I did not do the compass mot on this, nor did I look at vibrations. That is also the reason that I did not include a log file as I don't want to waste your time looking at it, however, a brief reply with some ideas would be appreciated.

Thanks!
Alex P.

Hi Reuben,

Yes, you are correct. Flew my copter today again, no problems in all modes, still can't figure out what happened about the loiter crash yesterday. Nothing is damaged though. Still Learning to diagnose from logs. Will still post a log, if someone can have a look and figure out what happened.

Thanks for the replies Craig and Reuben.

Attachments:

Hi,

I have a similar problem on my octa-quad, not an octa so I dont know if this is related or not but I thought it worth mentioning. It descends very slowly, sometimes even to the point of hovering at times and at times rising a little.  it also ascends very slowly if I am in loiter or althold. How does your ascend in those modes?

as you probably already know, you really should check your vibration level and run the compassmot :)

John

Hi Randy, ok did alot of testing on the bench

Test 1

Setup.

Laptop running MP 1.2.75  RFD 900 on ground station using a 2cell lipo through a 5v reg.  

current quad octo config, 

5v reg supply for apm and reciever

another 5v reg for RFD900 (grounds are tied, 5v seperate)

NO SPEEDIES CONNECTED.

RFD settings are 57600, air rate 64 (back to default config)

Connects fine through modem. (no usb cable in sight...)

I can wiggle the vehicle around and see Artifical Horizon (AH) responding pretty quick.

Ok so now I arm the vehicle, and raise the throttle to hover point ~50% and wiggle at similar rate as before..... AH getting limited data though, I am lucky if it moves every 5 seconds.

NEXT test...

Install current firmware (3.0.1) from MP for quad

Std Quad-X config on apm (2.5,) 

(this is a same setup but secondary unit to the one above.)

APM on the bench, connected with RX (ppm sum rx, frsky), RFD 900 NOT Connected at this stage.... 

Connect via USB, ARMED,..... throttle up, no problem (as expected)

DISCONNECT USB, Connect rfd900, Connect, arm throttle up no problem.

Next test Hexi config. ran through same procedure as last one, same results

Now the interesing one. 

Std OCTO config.

Connected via USB,.... wiggle and AH ok..... ARM raise throttle and HELLO we have a slowed AH again. much quicker than through RFD but none the less slowed.  Same test through RFD and very unresponsive.

I use these for photogrametry work with many waypoints on missions, It would be nice to find a solution.

Can the dev team do the similar testing for themselves and tell me if they see the same thing... Don't think the type or frequency of modem is an issue, just the fact that it is there...

BTW I am a avionics tech who has been operating UAV's professionally for many years (over10....)

I am pretty sure this is in the code somewhere....

Any help would be much appreciated!\

Cheers

Steve

Hi Randy, ok did alot of testing on the bench

Test 1

Setup.

Laptop running MP 1.2.75  RFD 900 on ground station using a 2cell lipo through a 5v reg.  

current quad octo config, 

5v reg supply for apm and reciever

another 5v reg for RFD900 (grounds are tied, 5v seperate)

NO SPEEDIES CONNECTED.

RFD settings are 57600, air rate 64 (back to default config)

Connects fine through modem. (no usb cable in sight...)

I can wiggle the vehicle around and see Artifical Horizon (AH) responding pretty quick.

Ok so now I arm the vehicle, and raise the throttle to hover point ~50% and wiggle at similar rate as before..... AH getting limited data though, I am lucky if it moves every 5 seconds.

NEXT test...

Install current firmware (3.0.1) from MP for quad

Std Quad-X config on apm (2.5,) 

(this is a same setup but secondary unit to the one above.)

APM on the bench, connected with RX (ppm sum rx, frsky), RFD 900 NOT Connected at this stage.... 

Connect via USB, ARMED,..... throttle up, no problem (as expected)

DISCONNECT USB, Connect rfd900, Connect, arm throttle up no problem.

Next test Hexi config. ran through same procedure as last one, same results

Now the interesing one. 

Std OCTO config.

Connected via USB,.... wiggle and AH ok..... ARM raise throttle and HELLO we have a slowed AH again. much quicker than through RFD but none the less slowed.  Same test through RFD and very unresponsive.

I use these for photogrametry work with many waypoints on missions, It would be nice to find a solution.

Can the dev team do the similar testing for themselves and tell me if they see the same thing... Don't think the type or frequency of modem is an issue, just the fact that it is there...

BTW I am a avionics tech who has been operating UAV's professionally for many years (over10....)

I am pretty sure this is in the code somewhere....

Any help would be much appreciated!\

Cheers

Steve

Have you looked the this in the parameters?
Waypoint Descent Speed Target (SR3_SPEED_DN)
Defines the speed in cm/s which the aircraft will attempt to maintain while descending during a WP mission

Range: 0 1000
Increment: 50
Units: cm/s

Here's the URL.
http://copter.ardupilot.com/wiki/arducopter-parameters/#Waypoint_De...

First time in a while that I post something in this thread again. I'd need some advice.

I changed the drive train on my copter. Before I had 2830-800kV motors with 10x4.5 props. Now I have 4822-390kV motors with 15x5.5 props. I didn't change anything else - also didn't retune yet. At first glance, the copter seems a bit overtuned, showing some wobble in ground effect and some bouncing when letting the stick loose from extreme left or right. Otherwise, it seems ok. Loiter without wind is fine, wind in loiter causes slight wobbling and wandering around, although the latter might have been caused by bad HDOP. Forward flight shows partially ugly wobbling.

I do see a massive increase of vibration in the log but it's generally still well within the limits.

Now, my questions:

  • What kind of PID change would I have to expect from this kind of change in the drive train? Rather higher PIDs or rather lower PIDs? When retuning, in which direction shall I rather go?
  • My guess is that much of the new vibration comes from the overtuning, because the wobbling comes mainly with wind in loiter or appears in forward flight. Is this a reasonable assumption?

Logfile is attached.

Attachments:
That's an error from the auto generated parameter docs. There is no SR3 params related to behaviour. SR3 params are for the telemetry serial port

Reply to Discussion

RSS

© 2016   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service