ArduCopter 3.0.1 has been released and is now available in the Mission Planner, firmware.diydrones.com, GitHub and the new Downloads Area.

Warning #1: Compass calibration and reducing interference is far more important than with 2.9.1b

Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).

Warning #3: optical flow is not supported but will be back in the next release (AC-3.0.2 or AC-3.1.0).

Warning #4: loiter turns does not maintain altitude.  This bug will be fixed in AC-3.0.2.

Warning #5: This release has only been lightly tested on Traditional Helicopters.

Improvements over 2.9.1b include:

  • Inertial Navigation for Loiter and Auto meaning much more accurate control (Randy,Leonard,JonathanC)
  • 3D navigation controller follows straight lines in all dimensions between waypoints (Leonard,Randy)

         WPNAV_SPEED, WPNAV_SPEED_UP, WPNAV_SPEED_DN, WPNAV_ACCEL allows configuring speeds and acceleration during missions

  • "compassmot" to compensate for interference on compass from the pdb, motors, ESCs and battery.  (Randy,JonathanC) (Set-up video here)
  • Safety improvements:
    • simple Tin Can shaped Geo Fence
    • pre-arm checks to ensure all calibration has been performed before arming (can be disabled by setting ARMING_CHECK to zero).  (video description here)
    • GPS failsafe - switches to LAND if GPS is lost for 5 seconds
    • stability patch improvements to stop rapid climbs in very overpowered or overtuned copters
  • Circle mode improvements including "panorama" when CIRCLE_RADIUS set to zero (Randy,Leonard)
  • SONAR_GAIN parameter added to allow better tuning of sonar surface tracking
  • CH8 auxiliary switch (same features as CH7)
  • works on PX4 (some minor features still not available) (Tridge,PatH)

How to upgrade:

1. Make sure you are using Mission Planner 1.2.59 or newer (get it here)

2. Click on the MissionPlanner's Hardware, Install Firmware screen.  The version numbers should appear as "ArduCopter-3.0.1", then click the appropriate frame icon and it should upgrade as per usual.

3. Reduce the Loiter and Alt Hold PIDs if you have modified them from the defaults.  The modified PID values for the 3DR frame can be seen in the image below.

Note: Nav parameters have been combined with Loiter so do not be concerned if you can't find them.

4. Although not directly related to this release, if you purchased an APM prior to March of 2013, update your PPM encoder to the latest firmware (instructions here).

5. Try out the new version in stabilize mode first, then alt-hold, then loiter and finally RTL and Auto.

Numerous How-To videos are available:

Special Thanks to MarcoDaveC and the large number of testers on the pre-release thread who put their copters at risk during the extended testing period.  Some of their videos can be found hereherehereherehere and here.  Thanks also to MichaelO for the MP changes required for this release.

All feedback welcome.  Please put your questions, comments (good and bad!) below.

Tags: 3.0.1, ArduCopter, DIYDrones, Release

Views: 351713

Reply to This

Replies to This Discussion

Hi All.. Hoping for a little help with log files on RC5. All the info I can find relates to Windows and with iOS it all works quite differently. I am struggling to just simply navigate to view the info I am looking for? I am in the initial flight tuning stage of a new Pixhawk on a 950mm Hex and just starting to do a few hover flights etc to check my data in logs. It is not familiar when using the graph controls etc. and am hoping for a little guidance on how to select the right info from the logs and how to adjust 7 view. It's not as simple as grabbing a section to zoom etc? Any help would be great.. Below file is screen print of first hover and graph gyro x,y,z. The values look good, but I'm not sure with the new graph tools that i am viewing correctly? And... um.... What next?

Attachments:

Hello,

 

I have three AP;  one 2.0, another one 2.5 both are from 3DR and one 2.5 from chine that I used to run some test

 

Two month ago I burn the 3,3 regulator of the chine one, so I read the topic with the procedure to change it and did.

 

When I was in the investigation process to find a solution I think that somebody had written that if you installed de 3.0 release in a chine AP board you could burn the 3.3 regulator.

 

I have my test chine board again alive and I have installed 2.9.1 release and is working with no problem a small test quad. , but I would like to installed the 3.0 firmware.

 

I would like to know if somebody else has read what I think I read, if I am right or wrong.

 

I am looking forward to hearing from you guys any comments.

 

Thank in advance, Leopoldo

If you burned the 3.3v reg., then it is burned no matter which firmware you install. The reason why your copter seems working with older 2.9.1 firmware is because those running at lower SPI speed and masking the problem. 

The problem is there, it just that you don't see it. Your IMU sensors (gyros, accels.) are still exposed to 5 volts which they are designed to work with 3.3volts only...

The only solution is to replace the regulator...

hello every body

i need some body help me with compiling arducopter code that is presented with arduino IDE

i have a code and i will attach it here that when i want to compile it, i encounter with this error

actually it is not an error but is an disappointing message that says the memory which has been used is 12 percent more than it is allowed











Build options changed, rebuilding all

Sketch uses 291,244 bytes (112%) of program storage space. Maximum is 258,048 bytes.
Global variables use 5,849 bytes (71%) of dynamic memory, leaving 2,343 bytes for local variables. Maximum is 8,192 bytes.
processing.app.debug.RunnerException: Sketch too big; see http://www.arduino.cc/en/Guide/Troubleshooting#size for tips on reducing it.
    at processing.app.Sketch.size(Sketch.java:1676)
    at processing.app.Sketch.build(Sketch.java:1590)
    at processing.app.Sketch.build(Sketch.java:1509)
    at processing.app.Editor$DefaultRunHandler.run(Editor.java:1915)
    at java.lang.Thread.run(Unknown Source)

it is the released code and i dont understand what is the problem with that. i expected it to be compiled and gotten ready for upload

it would be a great kindness of person who help me in solving that

Attachments:
@mohsein,

No need to worry, this is a common cause of concern. Due to Arducopter firmware's extended features, the code size has blown up over time than what APM's flash can handle. You simply have to go to APM_Config.h (or one of the header files where all #defines have been set). Comment the features you don't want (e.g.Camera mount, agriculture spraying, etc.. ), see the file carefully.

Compile and make sure it does not complain. If it does, carefully comment // more features you can do without.

Hope this helps!!

Regards,
Shyam

Hello Shyam

thank you for your concern about our problem

i did what you mentioned and i commented many defines that was not necessary for my job

how ever it did not change any thing and still i am getting this error

hope to find the solution once

any help will be appreciated

thank you

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service