Wich parameter do i have to change to get the Copter more faster on RC inputs?
I have to pull full forward to move forward, backwards its fast enough.
Flight is stable.

Thanks,

heckmic

Tags: Arducopter, PID, slow, stable

Views: 405

Reply to This

Replies to This Discussion

Stabilize P controls how fast your control input is used to rotate the copter.

The Problem is, when i use a bit more P it starts oscilating.

See AC2_Tweaks

 

"My copter is too sluggish : Lower your gain in RATE_ROLL_P, RATE_PITCH_P, and or raise your STABILIZE_ROLL_P, STABILIZE_PITCH_P gain." If adding Stabilize P is not good for you, try lowering gain in Rate P?

 

Also, see the OpenPilot PID Tuning video for some examples of how PID tuning results in, or eliminates oscillation. 

Thanks for your reply.

 

Which parameter is it in the new Gui?

 

Stabilize Roll (P, I, IMAX*100)

or

Rate Roll

From your symptoms, either Stab P++ or Rate P--. Or both.

I might have that mixed up, someone let me know if I am confused.

Are you only changing roll? Pitch is forward, backwards, but I always keep pitch and roll the same.

No. I changed both. Same Values. With this P value its stable but reacts very slow on RC inputs. What is ment with P-- or P++ (increase or decrease?). The Problem is, when i use a bit more P it gets oscilating an when i use less P its getting more slower on RC inputs.

 

Which "P" are you increasing, stabilize or rate?

stabilize

ok, try reducing your rate p then. Change your stab p back to no oscillations, then begin reducing rate p.

Also, did you watch that video? He shows sluggish input in one of his examples.

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service