When I try to calibrate Compass it displays "BAD compass health" error I have 3DR UBlox GPS + Compass Module and I disabled failsafe option then it armed and fly well but it's yaw motion and loiter mode not working can anybody guide me how i can remove this error?

Views: 3729

Attachments:

Reply to This

Replies to This Discussion

I notice that BAD compass health too! (<2.0 hdop, 10 sats)

Same here. :-(

Me too, with version AC: 3.1.0 (build for Pixhawk) What version do you have?

Menno

Me too.... but I am with PX4

And me too on apm2.5.2 , any solution?

Mee too, on APM 2.5 I have double and triple checked that I properly cut connection between pads on APM to disable on board compass. I can see the board all the way through so I think the jumper is cut. However now I see 'bad compass health' on mission planner and compass reading off 90 degrees. For some reason the on board compass on APM seems to still be working because I see copass movement on mission planner but when I move the ublox compass I see no movement. Any ideas?

 

 

I have the EXACT same problem.  off by 90 degrees and no change direction change when I move the external gps/compass.   I do, however, have a GPS lock and it looks accurate.  Any help would be appreciated.

Same here.  What is up with this?  It just suddenly started this behavior.

same for me.

I can not calibrate the compass (no data appears on the Mission planer window of calibration) but I can see the compass movement in the Flight Data window.

Even it is show bad compass health, seems it is working.

Any idae?

I too had "Bad Compass Health" until I moved the telemetry wires away from running along the top of my Pixhawk.  Any wire carrying electric current produces a magnetic field circling it.  The more electric current the more intense is the magnetic field.  Electric Motor wiring is the worst, however other lessor current carrying wires can also affect the compass if close enough to the sensor.

I verified that my 3.3 regulator wasn't blown, checked all the hardware, etc.

I did the calibration outdoors many times, away from any interference, to no resolve, no cell phone in my pocket, nothing to interfere. I checked and rechecked my wires, mounted on a mast, twisted the power wires, everything. I am using an APM 2.6 on a DJI F550 with Spektrum AR8000/DX8 setup.

Here is the fix I used, FINALLY after hours of fighting this frustrating problem.
I redid the entire Mission Planner wizard, but the difference this time that seemed to work was, 
first, I uploaded the firmware to the APM 2.6 for the ArduRover, and then back to the ArduCopter. This was after
trying to hard reset the APM 2.6 through the CLI, which did not work, as all  I ever saw in the Terminal
window was gibberish. 
Maybe there was some setting in the Mission Planner that was inconsistent with what the compass was telling it?
I don't know for sure, but it worked.
Good luck to anyone that encounters this issue, I hope this fix helps a few guys out there.

did u fix it? 

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service