Hi Everyone I have run into some compile issues while trying to compile V10Release of qgroundcontrol.

 

Following the instructions on https://github.com/pixhawk/qgroundcontrol/tree/v10release When i try to compile it using Qtcreator, i get the following error.

/src/ui/MainWindow.h:52: error: AS4Protocol.h: No such file or directory

Would appreciate  it if anyone who has successfully compiled this gcs gives me some pointers

 

Thanks

Srinath

 

 

Views: 819

Reply to This

Replies to This Discussion

Hi,

 

Please note that you're trying to compile a non-master branch. Any branch different from master is a developer / experimental branch and only recommended for advanced developers. Please also note that this version of QGroundControl will only decode MAVLink v1.0 (which isn't out yet) and which is not yet deployed to the autopilots. If you're aware of this please go on. There is a v10release branch in the MAVLink repository as well for those wanting to try out the new version. APM and other autopilots will soon upgrade to this.

 

Besides these comments the reference to AS4Protocol was indeed bogus and I've removed it - thank you for the report! Please pull again via GIT to get the update.

Hi

Thanks for the info, i tried getting the version from git
using
clone git@github.com:pixhawk/mavlink.git

To which i get the response
Initialized empty Git repository in /home/srinath/Qgc/mavlink/.git/
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

So i downloaded the source code as a .zip and followed the instructions to compile it using qt
It compiles with 19 warnings
But finally doesn't create an executable.
After creating the *.o object files, qtCreator quits with the error
Starting /home/srinath/pixhawk-qgroundcontrol-bfd33e1/qgroundcontrol...
Failed to start program. Path or permissions wrong?
I go into the directory and can't seem to find the compiled program anywhere.

So what am i doing wrong?

Update

 

I didn't want to create a git account. So i decided to download the master versions of mavlink and qgroundcontrol.

After unzipping both, i keep them at the same directory level.

Rename them as mavlink and qgroundcontrol respectively.

Then build with qtCreator. And it works ..:)

I encountered the same problem with the git's permission denied error and Qt Creator error. 

 

I downloaded source code for both qgroundcontrol and mavlink. After extracting both zip files, I moved the downloaded mavlink contents to qgroundcontrol\thirdParty\    by replacing the original mavlink folder that comes with the qgroundcontrol zip.

 

Finally I get the QtCreator builds the program successfully. Hope this helps.

Hi!

 

Thank you all for your feedback, the wiki instructions were indeed a bit fuzzy. What went wrong was:

 

1) The git link was to the push-repository (its now the read-only repository)

2) The MAVLink version in the thirdParty directory was outdated (its now updated)

 

I have updated / improved the documentation to reflect this:

 

http://www.qgroundcontrol.org/dev/build_source

Hi

I still can't seem to get the gcs to connect with the copter, what should be changed in the code, before uploading it to the copter?

Does Arducopter 2.0.4x still follow the mavlink protocol?

 

 

Hi I am still getting errors when trying to install qgroundcontrol. I have followed the link above and still get --

richard@richard-laptop ~/directory $ git clone git@github.com:pixhawk/mavlink.git
Initialized empty Git repository in /home/richard/directory/mavlink/.git/
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

Ihave managed to get QTCreator installed but that is a far as I got before getting stalled trying to load mavlink and qground control following the steps outlined in -

 

http://qgroundcontrol.org/dev/qt_install_guide_linux

 

regards richie

 

Hi Richie,

 

You have the wrong GIT URL. The guide you've linked recommends this URL, which works:

 

git://github.com/pixhawk/qgroundcontrol.git

git://github.com/pixhawk/mavlink.git

 

hi, thanks for the update but i am no closer to getting it to work.

in the terminal I am trying the following:

cd auto  ## having made a file called "auto" in my home folder.

git clone git://github.com/pixhawk/qgroundcontrol.git

## after a few seconds I get the error:

richard@richard-laptop ~/auto $ git clone git://github.com/pixhawk/qgroundcontrol.git
Initialized empty Git repository in /home/richard/auto/qgroundcontrol/.git/

github.com[0: 207.97.227.239]: errno=Connection timed out
fatal: unable to connect a socket (Connection timed out)

I have also registered and gone through the process of setting up a passkey at GIT.

and tested the git connection with success.

regards richie

I tested the URL and it seems to be fine - maybe this is a firewall issue. Could you please try this HTTP URL?

 

git clone https://github.com/pixhawk/qgroundcontrol.git

Did you get it to compile?

How do you make your APMega talk with QgroundControl?

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service