Hi Guy's I had a crash today with my skywalker. It has never battered an eyelid at anything I have thrown at it and has flown many missions without a hiccup. Today I went for a fly at my usual haunt. I uploaded an auto flight with 4 waypoints (I have flown these waypoints before) and hand launched after waiting approximately 5 minutes for the GPS fix. I flew around for a minute or two whilst I positioned the goggles on my head and when they where on I flicked through stabilise to Auto. Once it went into Auto the engine reved up and the skywalker banked slightly to the left (to get on track) and pitched down violently, I tried to pull up but it did not respond at all, I went to Manual mode and by that time it was too late.

I did notice my airspeed went nuts but it was windy around 6 Knts variable. Also the HUD was not reflecting my pitched down angle, Also Ignore the Voltage on the screen, The Voltage has not been calibrated.

I have attached my .tlog, .log amd kmz file for everyone to look at. I have had a look but I can't decipher the logs. Also attached the FPV video as well as the Wing cam.

Another thing I noticed in the kmz file was showing I was flying in yellow stabilise but in actual fact I was in manual which should have been orange. the green in the middle of the yellow and blue reflects me going through Stabilise green to get to Auto black but the kmz shows me going into RTL which is blue. The OSD reflects me going into manual, taking off, flying then going through stabilise to get to auto, I never hit RTL ?

I hope it was something I have done because it was going so well and this was just unexpected.

Any info would be appreciated.

I will upload the Video's as soon as they get to youtube.



Views: 4327


Reply to This

Replies to This Discussion

Agreed, if it can fail it will eventually in this hobby. In these foamie planes we generally hard mount our servos making them very susceptible to vibration. Even an expensive servo can fail in a high vibration environment. It is worth balancing props for this reason alone. There is a reason most servos come with rubber grommets.

I'm not saying you didn't balance your prop or even that your servo failed, just a general comment about the fact that we hard mount frequently and this puts a higher stress on our servos.

Hi Ted. I am using Hitec HS-65 Karbonite servos. I did replace the servo on the ground but was getting the same results. If you where getting brownouts how where you powering your system ?

Hi Adrian,

My mistake was that I was not separately powering my APM with a BEC or battery and I had a servo wig out on me. The lesson being that if you attach anything to the output rail it can and likely will sometime fail or draw too much current, taking down the APM with it (unless separately powered) . I learned this the hard way, twice. This can even happen to a multicopter with no servos.

I was merely speculating or suggesting earlier, this may have nothing to do with the crash, but its worth noting for others reading the thread.

I'm not totally familiar, but does data logging include commands to the servos? Simply checking whether the pitch down was commanded or not would shed a lot of light on the crash. My APM data flash is busted so that valuable resource is an area of learning with ArduPlane I don't know enough about.
If you are using the APM Power Module to power the APM , and JP1 removed you wil not get brown outs. The bec from the ESC will power the servos independently from the APM.

Hello Adrian, 

     I figured Id chime in here as I had the exact same problem on the exact same airframe. I too was flying a skywalker 1900 and had many great flights until one day, when I switched from FBW-A to Auto, and the motor reved up and nose dived into the ground. After that, I was fortunate enough to have Andrew Tridgell, whom has already posted on here, take the time to walk me through my log files. What we found is that there was a massive amount of magnetic interference with the APM board from the ESC. If you pull your logs and look at the "mag_field", this graph should be linear. Mine was jumpy as all get out. My solution was to move some things around in the airplane to create more space between components as well as shielding what I could. Hopefully this isn't your problem, but it is definitely worth checking.

If you use digital servos they should go floppy if they fail and you might still get home in time for tea and medals.

Hi Gary I was using Hitec HS-65's all round. The elevator servo appears to be ok, even under load as do the others. 

Thanks Jamie. I will try and extract those logs tonight when I get home. I don't think it was interference but you never know. if it is I might use an external GPS Compass combo.

Hi Andrian,

Please check your motor thurst. I think it's important to make correct motor thrust on pusher airplane type. Fly in manual mode then full throttle, and notice if it has tendency nose dive.  I have similiar problem with SW1880, it happened when I switched from FWBA to Auto, while motor rev increasing then suddenly my SW nose dive! The problem solve after re-adjusting motor thrust.

Hi eko, Motor thrust was checked as part of the trimming on the first few flights. Half throttle she cruised nice, low throttle it slowly started to loose altitude and full power she would climb. 

I did see "Batt Low" on the HUD just before the pitch down??

Hi Guy, I did not have the C&V sensor calibrated, It was fully charged and received a smidge over 1000mah when charged. 


© 2016   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service