Hi everyone,

I'm building a heavy Octo for aerial photo & video based on the APM2 board + Carbon Core Octocopter1000 with 360 Pano Mount and Mega Radius camera mount.

The power is provided by two Turnigy nano-tech 6000Mah 6C batteries connected to 8 Himodel 40Amp ESCs powering 8 Tiger motor MT3515-15 400Kv motors with Master Airscrew 14x7 3-blade propellers fitted.

The theorical maximum amp draw for each motor is 29Amps making a theorical max Amp draw of 232Amps. I want to measure battery Voltage and current draw but the biggest AttoPilot Current & voltage sensor is rated for 180Amps Max.

I know I'ts impossible or near impossible to go to max Amps with all motors at same time doing AP but given that burning the Attopilot sensor will stop the power feed to the multicopter, and this will result in a more than sure crash, I want to be very conservative and not overload it.

Is there an option to connect two 180Amp sensors to the APM2 board (one on each battery) and get readings?

Two sensors should be capable of handling 360Amps and this would solve my problem.

Other sugestions?

Views: 4425

Reply to This

Replies to This Discussion

I also already use mission planner software with my dragon link

I designed with Nick Arsov and sell a hall effect current sensor (up to 200A), up to 8S

http://www.airbotservices.com/airbotpower.html

jbabio, I  have a heavy Y6 built a few years ago and still in the air.  In my case I have three parallel 5s, 5000mah batteries.  It works for me and my Y6, but I would not recommend three parallel batteries as this creates battery issues you can not anticipate.  Anyway, I use one AttoPilot 180A  sensor attached only to one battery.  In this setup the sensor will report the correct voltage, but reflect an incorrect current.  In mission planner you can set a parameter to adjust Amps per Volt, or amps reported per volt from the sensor.  Using an external battery monitor during flight the external battery monitor will report the max current during the flight, then find the AttoPilot max current recorded in the  telemetry log and calculate a new setting for the Amps/Volt parameter.  Repeat the process until the reported current equals the battery monitor results.  Like I stated, it works in my case, but is not generally recommended as failure of one of the two non-monitored batteries will not be reported to the flight controller, and the voltage of the remaining operative batteries will drop like a rock, faster than the FC can anticipate.

Also, I have been educated by those knowledgeable that the available current from multiple parallel batteries IS NOT additive, in other words if each battery can supply 100 amps then two batteries DO NOT provide 200 Amps.  My understanding is that this is due to the battery's internal resistance.  In my case I switched form 20C Batteries to 50C Batteries and Im fine.  In my case I have six 50 amp motors for a  theoretical 300Amps, (5S)  I hover at 80 amps and have never seen 200Amps reported.

On another note:  Check the wicki, I believe I have seen reference to a second battery monitor, However I have not chased down that issue and I don't know how the FC uses the second sensor data.

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service