I'm flying a DJI Flamewheel 550 with a APM 2.0, it's flying very nice. and using the DJI esc's and engines.

Sometimes in flight one engine is quitting the job. Only for half a second and then back to work.

Just enough time to recover :) The hardware seems ok, i checked the connections of the esc and the motor connections .. Is it possible thats it a software issue? 

The problem occurs sometimes in hover and also when flying a bit rough ...

Views: 2579

Reply to This

Replies to This Discussion

Peter,

     Could you try reducing your ThrottleRate P value a bit?  I haven't actually compared a "good throttle control" log to yours but this appears overly active to me.

You might even want to try adjusting it while you're flying using the CH6 Opt which can be set to "" on the ArduCopter Config page (you probably already know this but just in case).

BTW, your roll and pitch controllers (i.e. checked by looking at Roll vs Roll-In and Pitch vs Pitch-In looked pretty good).  Maybe your pitch P value could be a touch higher.  I guess you're using the ublox gps?  That makes a big difference to your loiter performance as I'm sure you know.

Peter,

     Sorry for all the separate replies..just looked at your video and it's very bad.  Now one thing is..is it possible that you also have a bad ESC or motor (or a bullet connector) and the problem has just developed over time that happens to coincide with the 2.6 -> 2.7.1 releases?

     The perfect test would be to go back to ver 2.6 of the code (i.e. download from the downloads area, then upload with the arduino ide), go into the cli and do a "setup", "reset" to reset all settings to the factory settings and try flying again.

     Another thing though would be to try and determine if it's a particular ESC/Motor that is always jumpy.  Perhaps disconnecting 3 of the 4 motors and try increasing the throttle to see if the motor responds smoothly or not would help?

-Randy

Randy, Thanks for the help! Really appreciate it!

Windy as hell here, but put throttle_rate on ch6.  0 to default

No difference to surging!!!

Ok will go back to v2.6 and video everything, need to wait for these winds to die out!, Once I'm done, will start a new thread specific to motor surging issues.

Hi Randy.

is there a option to disable this throttle compensation when is stabilize mode.. i just want the angle of the copter to be stabilized (Attitude) not a forward feed altitude "help".

This has been bothering me from day one of using APM. i know i can fly in acro mode to disable this but i still want the angle stabilization.

if there is not a Mavlink parameter that can disable this (i guess not) is there a way to disable it in source? Or will this interfere with the other modes in altitude holding?

Anyways i would like to see a variable on this in stabilize. like THR_RATE_STAB/STAB_THR_FEED from 0.0 to 1.0

-Svein

Hi Randy,

Thanks for your reply.

Did some more tweaking yesterday, quad is bit more stable but still go up and down a lot.

My AQ50D was holding the height so I assume it is more parallel to Alt Hold ?

I will take a video to show this.

As for the Sonar, I’m aware of the Shield and plan to do it, now I’m also know where to look for spikes J

Regards,

Tsahi.

 

today i tried again, stabilize mode, acro mode, auto mode.

all with motor hiccups, and the auto mode with no help from me.

In the logs where no input spikes, but still hiccups with an (random) engine :(

jos,

     Can you post your logs?  I'd like to double check that the radio spikes really have gone away.

I had the same problem. I had the PPM encoder software updated to V 2.2.68. The receiver is a Futaba R6208SB. I am now back to V 2.2.65 and have no problems with dropouts from the engine.

Still no luck to stabilize this.

try to normalize throttle but it suddenly goes up or down like motors get boost.

 

Attachments:

I've had a look at your logs and it all looks pretty normal.  I see you've disabled your sonar.  Indeed the spikes on the radio have gone away.

Have you calibrated your ESCs?

I think you're flying very close to the ground...so you will get some ground effect which will make it fly less smoothly although that doesn't sound like your problem.

Any chance you could make a video?

Carlos,

     Ok, I had to look up what the timing mode thing meant..but I guess i have seen that setting on ESCs and I think it has something to do with when the pulses are sent from the ESC to the motor.  In this case with the engine hiccups..generally people seem to think something has happened with version 2.7 of arducopter that has caused some pulsing of the motors...so my guess is it's unrelated.

I've had motor hiccups on my 3dr hexa twice so far that have resulted in crashes.  It was in stabilize mode.  I'm using a dx7 controller.  I'll look at the replies here to see if they help.  Just wanted to say i was having the same issues.

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service