FYI, when I tried to compile the lastest code with arduino IDE 1.0, the code generate a lot of errors but it work very smoothly with arduino IDE 0023.

Views: 2249

Reply to This

Replies to This Discussion


     I just checked in a bunch of changes yesterday to add support for Arduino 1.0 so I think it will work now if you get the latest code from trunk.  Remember to use the Arduino with the relax-patch which you can find in the download area (look for arduino-0100-relax-windows.zip - sorry we only have the windows version at the moment).  By the way we expect arduino will include this relax-patch in the next official release.

Thanks for the fast reply.

Anyone know of a relax-patch 'ed version for Linux ?

Hi, I use ubuntu linux and I had problems with this line that is in the library files.

  #if defined(ARDUINO) && ARDUINO >= 100
I had to change all the files with that line to
  #if defined(ARDUINO) && defined(ARDUINO) >= 100
if you cut and paste the following two separate commands while in the libraries folder
each line runs thru all the libraries files and find and replaces
find . -name '*.h' | xargs perl -pi -e 's/&& ARDUINO/&& defined(ARDUINO)/g'
find . -name '*.cpp' | xargs perl -pi -e 's/&& ARDUINO/&& defined(ARDUINO)/g'
after doing that you should be able to make with no errors
there is probably is a better way but this works for me.

what Arduino version are you using ? - all I got with the default version 0022 - was the relax-related errors.

I'm getting the same problem as Steven (March 4) but haven't made the code changes yet as I hoped there would be another solution. Have tried building with both 0023 and 1.0.1 and get the same errors each time:

C:/Users/Andrew/ARDUPI~1/libraries/FastSerial/../AP_Common/AP_Common.h:19:33: error: operator '&&' has no right operand

Any ideas?
BTW, arduino 1.0.1 release does have the relax patch:



     You're not using windows right?  Maybe linux?  Could you try replacing this line:

#if defined(ARDUINO) && ARDUINO >= 100

     with this?

#if defined(ARDUINO) && (ARDUINO >= 100)


The code no longer compiles with 022 because we've taken advantage of a couple of features of the newer arduino versions so I think we can remove that condition from a lot of the code.


I'm having trouble with this too. I have tried Arduino0100-relax, arduino-1.0.1-windows, and arduino-1.0.3. With all three of these I get a lot of errors! Any help?

If you use this arduino and follow the instructions on this page including setting the board type and sketch book locatoin it should definitely work.

Thank you Randy! That link helped out and so did these step by step instructions. 


I found the easiest way to "install" the libraries is to simply copy all the stuff inside the "libraries" dir from the download into the "libraries" dir under arduino. When you do this they will all appear under your libraries sub menu in the editor. Dont simply unzip everything to sketches and try and add and pick the add library menu option and navigate to the unzip /libs dir. The thing goes crazy and recursively copies itself.

Reply to Discussion


© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service