Hello, I am relatively new to this ArduStation. I attempted to upload the Ardustation demo program using the ftdi cable, but i recieve the error:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Any help/ suggestions would be appreciated to help me get this thing up and running.

Views: 3660

Reply to This

Replies to This Discussion

If you have your aircraft's xbee up and running with Mavlink, The blue light should be illuminated on the Ardustation even before you select start feeds. If it isn't then there isn't communication between your Xbees. Also, on my Ardustation, the red light never flashes. On my Xbee firmware that I have loaded, it indicates that the Ardustation's Xbee has power although this can be changed in the Xbees setup to indicate association. The blue light is the Rssi indicator so it also indicates received Xbee signal strength. I would check that both Xbees have the right firmware and have been configured with the same Panids. The copters Xbee should also be green and not red.

I would check your Xbees setup on both sides and 57.6k is the correct baud rate.

Now every thing working ,yess :)

I had forgot to glide the cli switch to flight mode. When I switch to flight mode the blue led light up.It is good to note that the engines must be armed in order to receive data, it seems so for me.

Thank you all for the help



Just adding a link to some additional information on the Ardustation


Colin has done some fantastic work with the code:









As an additional update to the postings here, one of my customers pointed out that the chip is the "UNO" on the Ardustation and needs to be selected to have the code compile and load without error!





Good point, Martin. I've updated the manual to remind people of that.

I'm having the same issue not being able to upload code to the Ardustation. The error message is:

Binary sketch size: 22752 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Here are my details:

-Arduino 0022

-Selected Arduino Uno (and have also tried all the other ATmega 328 permutations)

-ATmega is plugged in with the notch in the correct direction and A0-A5 labels all agree in direction

-Running Ardustation 2.0.11

-Using a 3.3V FTDI cable (http://www.sparkfun.com/products/8772) with up to date drivers

-Windows 7

Any more ideas?



Looks like the ATMega that came with my Ardupilot kit from 3DRobotics was bad. I had another ATMega 328 from a Duemilanove that I swapped in and the code loaded without a problem.

I'm getting the same problem and error displayed as Pat in the post post above.

I also purchased my Ardustation  from 3dRobotics and around the same time period as Pat. I'm wondering if mine could also have a bad ATMEGA. But I'll list my config and symptoms first because I'm out of ideas on what the problem is other than it isn't communicating properly.

-Tried using both Arduino Ver: 0.022 and Ver: 1.0

-Selected Arduino Uno

-Compiled error-

Binary sketch size: 22752 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Points of interest.-

- If FTDI cable is used to try upload. Then only the green LED comes on. But same compile error.

- If XBee Pro is used for upload. The green LED is on. The Red LED Blinks. The Blue LED comes on for a second or two, twice during upload. The XBee tx is seen blinking. However same upload error as above is reported.

- LCD Screen remains as fixed alternating rows of square blocks formed by the pixels.  Reset has no effect on this display. I remains the same no matter what.

- I have changed the com port speeds and configured as per a posted instructions but nothing seems to make any difference.

- Reset button has no observable effect on anything. Not the LED's or especially the LCD.

 Last, a question-

- On the station board I noticed a difference from the pictures of it. Two surface mount resistors ( think they are resistors) appear installed in the area between the i2c holes and the 100uf cap just below the bottom right corner of the atmega. On the board I received, these two resistors are not installed. I'm assuming there has been a recent change since the picture was taken, but I thought I would mention this just in case they should be there.

Addition to the above.

I've tested out both of my Xbee 900mhz units  on my laptop using Digi's X-CTU and they work fine. They talk to each other using two sessions of X-CTU.

So this seems to bring me back to the station itself. I keep going over everything on it and can't find any assembly or solder error. My solder skills years ago where nasa trained. Not bragging but they are still pretty decent and nothing looks bad as far as I can see.

I just have a feeling it is the ATMega at the bottom of this issue or one of the boards.

I have only primitive test gear these days being retired, So need something I can easily check that would point to the chip.

I just assembled my Ardustation and it behaves exactly as Terry described. I am unable even to load a boot loader getting the same sync error.

You cannot load a boot loader through FTDI so no that's not exactly the same error. Bootloaders must go through a programmer (and actual AVR or tinyusb) on the ICSP port. Only with a working bootloader can you then connect via FTDI. Bootloader is a small piece of code written to enable the serial port on the chip, otherwise, a cold boot, there is no enabled ports to connect to, the micro is blank. ICSP allows you to write to the eprom area where bootloader would reside. So yes, you could have a blank chip with no bootloader and get that message when trying to flash the program, but no you cannot fix it with a FTDI cable trying to flash the bootloader.


I finally got the ardustation working. Here are a few tips for others who may be having similar problems.

(1) Green light on with two rows of black squares is the default if the ardustation isn't programmed. If an Xbee is attached then the red LED will be flashing. Doesn't mean anything is wrong. (I never have gotten a chirp!)

(2) To verify that the boot loader is installed monitor pin 13 on reset , if it flashes high you are in business.

(3) When programming the Ardustation do not use later versions of ardurino or relax as you will get multiple compile errors. Use this version:    arduino-0022-relaxpatch.zip    

(4) Make sure you have the extracted ardustation sketch folder and library folder  in your defined sketch  folder . You also need arduplane or arducopter sketch folders and library folder in there.

(5)Make sure you have the latest FTDI drivers installed. ANd that thee cable is plugged in properly.

(6) Make sure your microprocessor chip is oriented correctly.

(7) Check for cold solder joints and verify polarity on capacitors which require it.

Hope this helps others like me.

Reply to Discussion


© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service