Not many people know but we have an piece of open source software for controlling an Antenna Tracker.  It's been built by Tridge (Arduplane lead developer) for use in the outback challenge.

Sadly we have no documentation and, as far as I know, nobody except Tridge has used it.  Still given Tridge's track record on building great software I suspect it works well and if it doesn't, I'm sure we can fix it.  So to not let this piece of code go to waste, I'd like some help from people who are interested to give it a try and help me figure out how it works.

Here's the little that I know:

  • It runs on any of our supported board (APM1, APM2, PX4, Pixhawk, Flymaple and perhaps VRBrain)
  • For APM1/APM2 users building the code is as easy as opening our hacked ArduinoIDE and selecting File > SketchBook > Tools > AntennaTracker and then building in the normal way.  For PX4/Pixhawk, our autobuilder doesn't automatically build a binary but I can provide one if people are interested.
  • It can control a Pan and Tilt gimbal like this or this found on servocity.com.
  • It may or may not require a GPS
  • It must somehow receive vehicle position updates from the ground station which has the telemetry radio that is connected to the vehicle. Maybe through a USB cable.  Tridge probably uses the python ground station, MAVProxy, to passthrough the vehicle position data to the AT but perhaps we can get MichaelO to build out a similar feature in Mission Planner.
  • I imagine this antenna tracker could also be used to keep a camera focused on the vehicle which might be good for easing the burden on creating videos of our vehicles.

So if you want to give it a try please do and stick any findings, questions or issues below. Alternatively Issues can go into the issues list.

I'll start sticking things into the wiki as they become clear.

Views: 56216

Reply to This

Replies to This Discussion

This is what I have currently:

Attachments:

Hi 

I have an issue it move's so fast it tips over 
in did try to set the max Rate in yaw gain but it makes no difference

Thanks 
Colin

https://youtu.be/avnlnGXJ-is 

I have a geared servo setup so it moves at the correct speed. Do you have direct drive or what? Try lowering P. Servo City has gears and gearboxes.

I finally got my tracker set up just the way I have always wonted it. I have it working with a Servo City gimbal since firmware 0.7 was out. I was using the stock servos that would get less than 360 yaw. I finally upgraded to continuous rotation servo for yaw and V1.0 firmware.

After a bit if tuning the V1.0 firmware is working with no problems. Not sure why some are having problems with it. I learned a few things during the process so if anyone is having problem I might be able to help.

.

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service