At first I put it down to a few corrupted entries, but after a few flights all my logs have looked something like this:

Some of those GPS points must be on another planet, they persist as far out as google earth will let me zoom!

Also, all the NTUN and CTUN entries seem to be corrupted, or not recording what they should. I can't see things like Baro_Alt and WP_Alt.

Any thoughts? 

Tags: 2.8.1, logs

Views: 231

Reply to This

Replies to This Discussion

I reflashed the firmware and reset the EEPROM before I went flying yesterday. Logs were even crazier this time. The log menu in the CLI gave me this:

12 logs
Log -23659, start 1, end 1
Log -23658, start 1, end 1

The only way to download the log was to dump to the CLI. I've attached what I got, but I can't make any sense of it. The KMZ that this log creates is meaningless.

I'd really appreciate if someone could let me know what might be going wrong here.

Apologies, log now uploaded. Had to trim it to <7MB

Attachments:
Any ideas? Is there a better place to be posting this? Not sure if its arducopter or mission planner that's giving me problems.

Actually, I tried to use APM Log Visualizer, and I got thousands of bad lines.

So something is up.

[Edit] Using my own 2.8.1 logs I mean.

http://diydrones.com/forum/topics/apm-log-visualizer-source-code?co...

Thanks, at least it's not just me. Does the mission planner log browser work for you?

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service