I bought this to connect to my genuine 3DR pixhawk.

http://www.csgshop.com/product.php?id_product=171

The green power led lights up and after a minute or so the fix led light starts to blink but the pixhwk never see's it. I can't find any documentation about the thing. I suspect I need to change the baud rate does anybody know if that's the problem and if so how would I go about doing that. Terminal? 

Views: 326

Reply to This

Replies to This Discussion

@Richard,

I have the same UBlox M8Q working with my Pixhawk as a secondary GPS on the Pixhawk. I had to make an adapter cable to connect the Tx and Rx lines from the M8Q to the Pixhawk GPS/Serial 4 connectors.

How have you connected your M8Q to the Pixhawk GPS connector?

I also had to manually program the M8Q with the 3DR configuration file.

Regards,

TCIII AVD

Thanks for the quick response! I soldered a header / pins to the M8Q then made my own 6 pos cable with power, ground, rx, and tx. But I did not program the gps with 3DR configuration file. Could you elaborate? Is that in mission planner? I have a Mac so I'm using APM Planner.

Okay I see it's windows only. I guess you were referring to this then? 

http://copter.ardupilot.com/wiki/common-ublox-gps/

@Richard,

You need to go to the uBlox website and get their GPS IDE tool and then manually configure the M8Q since you will get a message that the 3DR configuration file is not the correct file for the M8Q.

The way I configured the M8Q was to download the configuration of a 3DR uBlox/Compass module using the GPS IDE tool and noted every configuration parameter. I then manually uploaded and saved those parameters to the M8Q using the tool.

Yes, I used the tool to change the baud rate to 38400.

Regards,

TCIII AVD

Thanks Thomas. I dusted off an old PC and download the uBlox tool but can't  for the life of me get the gps connected. Updated the FTDI driver still no good. It sees the correct com port but never connects. Not sure what to try next other than re-do all the connections. It wouldn't be the first time some connection wasn't %100 with all the pins and wires temporality connected. Does the TX of the FTDI cable go to the RX on the gps? I seem to get mixed signals googling that.  But I must be getting close. Thanks again.

@Richard,

According to my notes, try the following:

Pixhawk pin 2 (Tx) to M8Q pin 3 (Rx)

Pixhawk pin 3 (Rx) to M8Q pin 2 (Tx)

Hope this helps.

TCIII AVD

Thanks I tried that but I have not been able to get it to connect to either the Pixhawk or the Ublox tool so I guess there is more going on that incorrect connections. Gonna re-solder the pins on the gps tonight and see if that's it.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service