I have received an unmatched pair of radios one at V 1.5 one at v1.3
I ordered a ftdi cable so I could attach the radio my pc. The mission planner fails with an out of synch message.
The radio is in boot loader mode (red led solid on). I need instructions to flash the radio.
The documentation page is very cryptic for a non programmer and non lunix user.
How can the radios be upgraded on a windows box if the mission planner fails?
Thanks Matthias

Views: 6721

Reply to This

Replies to This Discussion

3DR tech support got back to me this morning:

It is a known problem with the Mission Planer

They recommend to try the 3DR Radio Configurator from here:


But I get the same results ....   sync is lost during the firmware upload.

Does anybody else have this issue or a solution?

It happened to me a few times.  I just kept retrying it and it went on about the 3rd try.  Not sure why it's doing this. None of the other uCs I have flashed ever say anything about syncronization, so I have no idea what sort of "syncronization" the update programs think they need.

"Syncronization" is the bootloader on the chip that allows you to program over the UART (AKA serial connection) VS a dedicated ICSP (In Circuit Serial Programmer) port that requires an external programmer device such as the AVR MK2 or USBtiny or others for PIC devices.

What it's telling you is that it's trying to reset the bootloader and go into "program mode". It's known that this bootloader has a short time window, otherwise it's jumped into the running code.

Well I guess I could try a faster PC and see if that gets around the timeout issue.
Other than that I am stuck with a piece of electronic that lights up red when you plug it in.

The PC has little to do with it other than possibly the USB port. Obviously you really didn't understand what I was saying, it just means the software attempted to reset the hardware and for whatever reason, the device what not in program mode when it was expected to be.

I agree I have no clue. That's why I am asking for help.
But I am happy to learn... That what this is all about right?

Exactly, and sorry I came off that way. This still sounds like one of two issues. Either the driver and/or hardware USB to serial conversion has a problem (most if not all of the microcontrollers only talk serial port), or it's possible due to the microcontroller being used (actually trying to be used as a serial link between the two radios) it doesn't go into reset and thus bootloader program mode. Worst case, the code is just corrupted so bad on the micro that it needs to be reflashed with a bootlaoder with an AVR (or whatever "brand") of programmer via the In Circuit Serial Programming (ICSP) port.

Once you have the basics of how most microcontrollers work, it's pretty simple. Again, the basic problem is that in order program or flash one via te serial port, the bootloader code on the chip must come up in programming mode right when it first boots, otherwise, the only other way to program is via the ICSP.

Keep trying it several times in a row.  I've flashed the radios in both bootloader mode and in the normal fashion.  In boot loader mode it threw less errors.

You might try shorting CTS to ground during power up.  That should put the device into bootloader mode.  Maybe the red light is on for another reason.

If that doesn't work keep trying and posting back.  I had some trouble when I first tried.  My problem was using an old version of Mission Planner, which I thought was up to date since it kept downloading updates from the internet.  So try a reinstall with the latest mission planner and try the bootloader method.  If nothing else you can send it back and someone with a SiLabs programmer can probably fix it.


Thanks for your encouragement ....

I did all of the above except for shortening the CTS pin will try that ...as well

Shortening the CTS pin did not help either new message is can not identify radio...

Hawhoo, are you running V0.2 of the 3DR Radio configurator? Try re-downloading it from the same URL, then check the programs title bar for 0.2. That version includes an improvement for the bootloader sync issue. If it does not help, we can report to Michael O. that the issue is still not resolved.



Yes I am running 0.2.

Reply to Discussion


© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service