Hey guys, I want to connect my LidarLite v3 with a pixhawk. I used the configuration for the Lidar Lite v2 from ardupilot but it doesn't works. Can you please help me?

Pd. I want to work with more than one lidar lite sensor at the same time.

Thaks.

Views: 514

Reply to This

Replies to This Discussion

Late but worth adding. Had issues working out correct settings for mine too using I2C, but after getting some advice I set the RNGFND_TYPE parameter to 15 works straight away, address can be set to anything, it seems to be determined by the type parameter as well.

Hi Martin, are you running the latest stable version of your firmware? I'm currently running ArduPlane 3.7.1 and I have no option to set RNDFND_TYPE to 15, LidarLiteV3-I2C. 

Martin said:

Late but worth adding. Had issues working out correct settings for mine too using I2C, but after getting some advice I set the RNGFND_TYPE parameter to 15 works straight away, address can be set to anything, it seems to be determined by the type parameter as well.

The parameter descriptions in mission planner sometimes are not up to date it seems. If you check the full parameter list here and check the RNGFNDR parameters you can see type 15 is for lidar lite V3.

Daniel Carelli said:

Hi Martin, are you running the latest stable version of your firmware? I'm currently running ArduPlane 3.7.1 and I have no option to set RNDFND_TYPE to 15, LidarLiteV3-I2C. 

Martin said:

Late but worth adding. Had issues working out correct settings for mine too using I2C, but after getting some advice I set the RNGFND_TYPE parameter to 15 works straight away, address can be set to anything, it seems to be determined by the type parameter as well.

I'm having no luck with either of my LidarLiteV3 with ArduCopter - I've tried everything I can find about getting it to work. I'm wondering if either you can advise / provide small guide on what you did to make it work.

Thanks,

Ash

Hi Ashley

I was also facing the same issue. I was following the old guide for making the connections - http://ardupilot.org/copter/docs/common-rangefinder-lidarlite.html


There has been change in pinout wires of Lidar Lite V3 and the above guide does not work.

Refer to the official manual by Garmin for the new connections. - https://static.garmin.com/pumac/LIDAR_Lite_v3_Operation_Manual_and_...


Also, follow this guide for making correct connections/settings of Lidar Lite V3 with PixHawk running on ArduPilot firmware - https://www.lambdrive.com/depot/Robotics/Controller/Firmware/ArduPi...


Note - It works only with version V3.5.0

I tested on APM:Copter V3.5.0-rc6

For LidarLite v3 you must set RNGFND_TYPE = 15

I made a direct connection between lidar & pixhawk using I2C (without adding the capacitor but it is recommended as per the official manual) 

Hope it helps you.

Thanks all, I just connected the LIDAR through PWM. That seemed to work following the same steps as the v2 outlined in the ArduPilot documentation. Make sure your PWM rails are powered on the pixhawk if using this method! 

What if you want to connect more than one sensor?

Btw, thanks all. 

Daniel Carelli said:

Thanks all, I just connected the LIDAR through PWM. That seemed to work following the same steps as the v2 outlined in the ArduPilot documentation. Make sure your PWM rails are powered on the pixhawk if using this method! 

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service