ok so I'll start with equipment:

Adrucoputer quad 1.1 kit pre soldered

880kv motors and 12x45 props.

30amp escs 28cm full holes arms.

radio Futaba 7C with receiver that comes with it.

configuration:

frame + and gps and magnetometer not connected. radio is factory default settings except channel 3 is reversed and failsafe is set to normal.

issues:

so my issue is doing the motors test http://code.google.com/p/arducopter/wiki/AC2_Props_2

only 3 motors of the 4 spin, only after I've run setup. configured radio turned off magnetometer and set all the modes to stabilise run level and set the frame to + using the windows tool. 

If i factory reset the APM and then run the motors test it works fine all 4 motors spin in order. then i configure it and it fails.this is repeatable.

Firmware is 2.5

aside: i also have and issue put together the dome and landing gear M3 screws don't fit in the holes by a fraction any ideas how to sand the holes so they are bigger ?

Views: 831

Reply to This

Replies to This Discussion

Don't know why you have reversed channel 3 on your radio.

Have you calibrated your radio.

Normally pitch is reversed in mission planner radio settings.

Have you calibrated the ESC's?

Are you using Mode 1 or Mode 2 radio.

Are you trying to fly in + mode or X mode?

Buy a 3mm drill bit from the hardware store and twist it through the holes if you don't have a drill.

calibrated the ESCs

radio is mode 2

without reversing the channel 3 on the radio it goes the wrong way in the setup program.

I'm flying in + mode... when I change to x mode and run the motors test in cli. It still fails except it misses a different motor so it can't be a wiring issues.

maybe factory default the ESC and start again ? (I assume I have to do that individually with the radio) 

It sounds completely odd to me.

Have you got any photos of your setup or video of the motor behaviour.

I fly in x mode with a mode 2 radio.

The only channel I reverse is the pitch channel in mission planner radio setup.

starting to think it's just me being too asleep.

got out the multimeter today to trace wires to realise i had the APM pointing the wrong way. and I've noticed that with the motors test some motors spin faster than others so i think i need to reconfigure the esc again. ok done that and it's fixed it all 4 motors spin in motors test

quick question do you configure the radio first or the ESC first ?

and when it says in sequence which one is the starting motor ? http://wiki.ardupilot-mega.googlecode.com/git/images/ACM_prop_derec... the one marked 1 ?

No Problem

You have to calibrate radio first.

For the ESC's I use the all at once method not individual.

So you cannot do this until your radio is setup and calibrated.

The first thing I do is put a dymo label on each arm with the motor number and the propeller direction. You cannot keep this in your head you must label the motors and direction.

The order the motors spin in the test depends on whether you are + or X I think.

Like I said I am setup for X mode so my motors go 1 4 2 3

Looking at that diagram however its probably the same for + mode.

Like I said label the arms with the motor number and the prop direction before you do anything else.

 

Ok Manly so i have a record

Don't click the calibrate radio button until AFTER you've turned your radio on. my low point on the throttle being sent by the receiver with the radio turned off was a smaller value that with my throttle at the lowest point on the controller so my ESC calibration was failing and so was the motors test because the APM was sending too small a value to spin the prop !

Need to configure the magnetometer again and double check my props and i might actaully get to fly it tomorrow !

Aside I also got a 3mm drill bit today and it fixed up my issues with the landing gear not letting the screws fit in. thanks for the tip !

youtube video

success except for hit a tree backyards are a bit small when you have no idea how to fly.

sorry.. but.. what is "mode 1" or "mode 2" ? I have to configure the radio as a mode plane or helicopter?

Mode 1 is the configuration for a transmitter in Australia. The throttle and ailerons are on the right stick and the rudder and pitch on the left stick.

Mode 2 is the normal set up for the US where throttle and rudder are on the left stick and pitch and aileron are on the right stick.

I am in Australia but have converted my transmitter to Mode 2 becuase I find it much more sensible.

Your radio should be set for a plane rather than helicopter.

ok.. thanks friend...

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service