Hello all. 

I've connected a Lightware SF10/c to my pixhawk serial 4/5 port as the instructions here show:http://copter.ardupilot.com/wiki/com...re-sf10-lidar/

My SonarRange is flat on 0. I can see that the unit is powered up because I can see the dot on the floor with a digital camera. I've triple checked continuity of the cable I made and I also (using the cable I made for the Pixhawk) with small jumpers stuck in the little connector, attached it to a USB to Serial adapter and with Putty I can see the distance just fine.

I dropped it down to 9600 baud, still nothing.

I'm new to pixhawk/apm world so I'm not really sure how to troubleshoot. I've double checked the wiring.

I currently am running firmware 3.3.2.

Lastly, this is still not done being built. This is my first experience with a Pixhawk. I'm upgrading from an Eagle Tree Vector. I'm not done rewiring. I am still waiting for a power module because I refuse to use the little 90A one that was supplied by 3DR. 

Thank you all.

Note (may be TMI): My parts list is as follows

  • Tarot FY680 Iron Man
  • Sigma Summit Motor Mounts (~740mm now)
  • PixHawk Controller
  • Mauch 4-14S 200A Power Module (pending delivery)
  • Quanum MT 3510 630KV
  • Turnigy K-Force 30A (Opto)
  • Zippy Flightmax 8Ah 6S 30C or Venom 6s 12Ah 30C
  • 13x5.5 Carbon Props
  • 3DR uBlox GPS/Compass
  • PX4FLOW Optical Flow Sensor
  • Lightware SF10-C LIDAR Altimeter 0-100m
  • Turnigy 9XR Pro
  • Floureon 915MHz Telemetry
  • 2W 1.3GHz NTSC Video Transmitter
  • HawkEye DTF-UHF 1w 16ch

Views: 2600

Reply to This

Replies to This Discussion

Got it, thanks. We're still digging through the code to find where the bug was hiding. 3.3.3 should include all the LiDAR features but we haven't yet verified what is available in each of the flight modes of this version.

We have an SF10/C connected to our pixhawk using serial 4. We tried custom firmware provided by lightware, 3.3.2 and 3.3.3rc2 but all of them result in the quad failing to hold altitude. It drifts down faster and faster, until the throttle is lifted up and after a delay it gains altitude again.

We have a test drone with a lidar-lite on the Iris+ and this works great. The response time from waving your hand under the lidar lite to getting a decreased reading is less than a second. However waving a hand under the Lightware SF10/c takes 2-3 seconds to record the change. Could this lag be the cause of the problem?

Setting serial 4 to Mavlink bypasses the SF10/c and the quad uses the barometric altimeter and holds it height as normal.

Anyone else seen this behaviour before?

@Justin - have you checked the settings in the SF10/C itself? It comes with some filtering options and these may be turned on - they can increase the response time. Also, there are some smoothing/response parameters in the setup of the AC software, including things like throttle response rate.

The filter was indeed set to on. We have switched it off. Testing will take a while since our quad crashed for reasons unrelated to the laser alt and will be returned to the manufacturer for testing. Could be 2-3 weeks before we can test the SF10/C on the new quad.

Are any of the "smoothing/response parameters" in the pixhawk firmware related to the SF10/c? As I mentioned, flight performance is normal when the SF10C was disconnected.

The extended kalman filter would do some filtering on the laser altimeter, Do you think there are some arducopter parameters to change/look-at that will affect the responsiveness of the SF10/C?

Interested in this post.

 Also, any reason why the SF10/C can't work well connected via ADC on the pixhawk. Would like to keep serial 4 for RTK GPS.


Go with I2C if you have spare ports. Supported in 3.3.3rc2 and firmware release will probably be within a few weeks.

Yes, the SF10/C does work on analog but you will find that with the analog span set to 100m the effect of system noise starts to become significant. At shorter spans this is less of an issue, so if you're specifically looking for operation over say, 40m, then you should reduce the analog span accordingly to reduce the effects of noise.

If I remember the Pixhawk setup correctly any of the available serial ports can be used with the SF10 and SF11 families. 


 Just tested to see if it would work on I2C in the latest beta release [apparently supported in 3.3.2rc2] but I am not getting any reading back on copter.

 Should the bus address or baud change?


There's a brief description of the various connection methods for the SF10 and SF11 here.

I2C doesn't use a baud rate so there's no problem with that. I think the default address should work but I'm going to check with my dev guy and I'll get back to you tomorrow.

Hi Duffy,

Have you set RNGFND_TYPE to 7?

Could you also confirm that it is the "sonarrange" output that you are checking?

Yes, did all the mods as described in the text:


You then need to configure the rangefinder parameters as shown below (this is done in the Mission PlannerConfig/Tuning | Full Parameter List page):

  • RNGFND_TYPE=7 (LightWareI2C)
  • RNGFND_MAX_CM=5000
  • RNGFND_GNDCLEAR = Your offset to ground""

The range findre works fine with the USB cable and the lightware terminal program.

 The firmware was 3.3.3rc2 and connection was using the I2C extender


PS yes, both sonarrange and sonarvoltage return 0

All sorted from my side,

 Just a question, where is the sonar range saved in the log file. Would like to geo ref images with height above ground in addition to baromatetrix/GPS altitude.


Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service