MAVLink message Disable fence floor failed (autodisable)

Hi,

I received this message during final appoach on an auto landing "disable fence floor failed (autodisable)"

FENCE_AUTOENABLE was = 2

I aborted the landing and performed a FBWA landing.

Looking at the source code this error is returned while trying to disable the fence floor during landing if "geofence_state == nullptr"

If this structure is nullptr then is this message telling me no geofence is set ? Which I thought it was I had defined one, set a return point and uploaded it.

Running ArduPlane V3.8.2 on a PixHawk2

Thanks. G.

Views: 48

Reply to This

Replies to This Discussion

May have worked it out, the clue is in FENCE_AUTOENABLE.

When set to 1, geofence automatically enables after an auto takeoff and automatically disables at the beginning of an auto landing.
When on the ground before takeoff the fence is disabled.

When set to 2, the fence autoenables after an auto takeoff, but only disables the fence floor during landing.
It is highly recommended to not use this option for line of sight flying and use a fence enable channel instead.

I did a manual takeoff, not an auto takeoff, so the fence never enabled, hence the error message.

So I the question now is can I have the fence always enabled (or enable on any takeoff) and still disable the floor during landing ?

Solved my own problem. I assigned fence activation to a channel that is always on, fence floor still deactivates on auto landing. MSG Fence floor disabled (auto disable).

Only problem will be if you want to land manually. So I have opted to totally disable the fence floor by setting FENCE_MINALT =0

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service