Hi Everyone,

I have been working on MonoPhan thrust vectoring EDF drones for a while now. I will posting my work on this technology here.

Below is the test video of my new nano unit with a nano FPV cam on it.

https://www.youtube.com/watch?v=echU1LLIjkg&feature=youtu.be

Views: 325

Attachments:

Reply to This

Replies to This Discussion

It’s been a while since the last time I can pick up the Mono for a test.

 

When I powered it up, the first thing that I saw was that the GPS reverted to the original code, going back to 9600. I couldn’t resolve this issue. I flash it with the code and save the config (which was the step that I have been missing when I first started) it works at 115200 baud rate, communicating with the I2C board. Then I power it off and if I power it on soon after, no problems. It works. But if it waits for a couple of days, it reverts back to 9600 baud and needs to be re-flashed. If anyone has some useful advice on this I would love to listen.

 

After re-flashing it and getting the GPS to work, took it up. These days it is very windy and I don’t want to test it in strong wind but I didn’t have an option as this is my only available time. Before the flight, you will see the baro kicking in as I holding it, moving it up and down.

 

During the flight the baro&GPS combination were activated multiple times. First one minute or so, I am trying to trim the unit to get it to stabilize a little bit. The first baro&GPS activation was at 2:10 minute mark and the unit lost altitude pretty fast, causing me to de-activate them right away. The second activation is at 3 minute mark and a couple of more times after that. You can hear the fan adjusting to compensate when I activate it. However, this test was more challenging than my first one last a couple of weeks ago, as the unit slowly lost altitude this time, with the fan kicking in and out in a rough manner. I didn’t change the settings, but that day there was no wind at all. I believe this is the difference. The sensor is affected by the wind. So, I will need to cover the controller and test it again, to see if it fixes that problem.

 

When it comes to GPS, I kinda felt some added stability when I activated it but the unit still moved slovly with the wind. So, I will have to make some PID changes on that. I was able to connect to the FC via Bluetooth and my phone, which will make it very convenient to test in the field with various settings.

 

I would appreciate any tested valuable methodology on how to set the PID for GPS and Baro, as I have never tried those before.

 

Thank you for checking out. Enjoy the video:)

https://www.youtube.com/watch?v=GypskvdVBKk

pic of the monobot

Attachments:

Carbon Fiber 64mm Indestructible Mono - Thrust Vectoring VTOL

 

This is a full carbon fiber MonoPhan Unit which I built for a friend of mine to be tested for aerial filming for wildlife protection. The impeller is buried into the carbon tube and the lateral wings extend to the top of the impeller to provide additional protection in case it is attacked by a raptor during the flight. The frame is rock solid. If it crashes, I simply re-attach the batteries and keep on flying:)

 

Working on installing the gimbal and the cam.

 

https://www.youtube.com/watch?v=9jNeEWIrNUI

 

https://www.youtube.com/watch?v=9jNeEWIrNUI

 

Very nice, compliments  !

The concept is interesting but the efficiency of the system must be quite low as it is usually with EDF.

I would like to give it a try  in the hope to increase efficiency I have quite a lot of RC unused hardware.

Would it be possible for you to share some informations so I will not reinvent the wheel ?

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service