I've been testing my purple board through the USB and it works good enough to replace an ArduPilot Mega 1 on an EasyStar.  Everything is connected and the power jumper is in so the ESC is supplying system power.

But, the APM2 will not start up on either ESC or UBEC power.  Even wired in, it still boots on the USB power, as it has always done.  The APM1 never had any problems with power on this plane and another APM1 always works on a T-28.

Has anyone seen this problem with ESC/UBEC power? 

Views: 2010

Reply to This

Replies to This Discussion

Colin: I don't think so. I suspect it's just a board that's gone bad for some reason. I'm not seeing any issues with other boards. Might as well send yours back to 3DR to be checked out. 

Hei Colin

I have exact same problem, but with my APM v1 board.

With USB cable conneted i get a fix, but powering the board with battery/esc i don't get a fix.

That probably means either your battery needs to be charged or your ESC isn't putting out enough power. Charge the battery and/or try a different ESC

Sounds like you've got a broken trace/connector somewhere. Does the blue LED come on on the GPS module itself? 

Yes, its blinking and satcount is mostly 2-3, gpstatus 1, gpshdop 9999 while indoors. But as soon as i remove battery power and connect usb i get lock and satcount goes up to 11 within 1min.

UPDATE

 

HI, the problem is still here.

After a day of configuration I've again the same problem, when I power on the board only Blue LED ON.

 

In debug windows It STOP load on: INIT GYRO.

 

After that message the board do not output any message. If I Press reset button, the board boot fine and work.

I've tried:

Arduplane 2.28 firmware

Arducopter 2.4.1 firmaware

 

Any idea? Defective Board?

 

this also happens to my apm2 board. led blinks normally if i remove the dataflash card. and when i put in the card there is a solid blue led light on boot. already tried to erase eprom but still the same. 

MarkO: Try leaving it for a few minutes--it may just be autoerasing the dataflash. If it doesn't eventually boot correctly (and then operate correctly from then on), contact customer support for a RMA.

Hi MarkO,

 

try to load the firmware from Arduino instead MP, for me has worked. (sometimes...)

It is a very strange problem.

 

thanks Guys!  after erasing the eprom and restarting several times, bootup seems to work fine now. 

Hi friends!
I have a problem with the startup of my AMP2, watch the video below it is a problem similar to

yours or a problem of BEC / UBEC because my engine only works when I turn my APM2 before

connecting it to the USB.

Please help me to fix this problem! I cordially thank

http://www.youtube.com/watch?v=xO1idkvcBb4

nobody can help me ?

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service