I received my APM2 yesterday. After a USB cable problem that have been resolved I've got another problem today.

Yesterday I was able to upload firmware and view sensors in mission planner.

A few hours ago I managed to power the board using output 5v bus (jp1 on) everything seems to be ok.

But now I can't connect to the board.

In mission planner :

MAVLink readpacket read error: Le délai d'attente de l'opération a expiré.
Mavlink Bad Packet (crc fail) len 0 crc 65535 pkno 0

When trying terminal mode no response.I can see the RX diod blinking when I send commands but TX diod never blink.

When I try to upload a firmware mission planner says "no heartbeat" (see picture)

Power led (green) is on

3dFix led GPS (blue) Blink slowly (0.5Hz)

A led (Red) blinks  (1Hz)

B led is off

C led (blue) blink quicker than A (4hz)

I'm a little out of idea. What can I do ?

Thanks for your help !

Views: 605

Attachments:

Reply to This

Replies to This Discussion

I have no idea.
But i have temporary the same problem.
You are not alone.
Michael

My problem seems also to be very similar, s.a. my post: http://www.diydrones.com/forum/topics/problem-connecting-to-apm2-wi... ....I can´t believe that it is a hardware problem since I can upload & run simple Arduino programs....but a software problem should apply to all the other users as well...it's really frustrating.

Reply to Discussion

RSS

DIY Drones Monthly
Newsletter

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2016   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service