Hello everyone.

We took our octocopter out over the weekend for it's first flight test and ran into a few issues that I was hoping to get some help with.
We are running the following: Cinestar 8 clone frame, T-Motor 3515-15 (400kv motors), 15x4 carbon props, Hobbyking Multistar 45amp ESC's, 2 x 4S 5000mah batteries (for test only, will be going to 6S 8000mah soon), and an APM 2.5. The APM has the latest 3.01 firmware installed.


The issues we have are:

1. Taking off: The octocopter is extremely had to get to take off. It tends to lift one side more than the other, which on a few occasions caused the props to hit the ground quicker than we were able to cut the throttle and we actually broke a prop. It doesn't seem to be the same side each time either, if we have the copter facing forward sometimes it would lift front too much and other times the rear, left or right. Once it actually got off the ground it seemed to hover quite level.
We went back through the accelerometer calibration, magnetometer calibration, set a new level by using level command in the terminal, and checked the radio was calibrated correctly (which it was), which seemed to make a small difference but the problem is still there. The ESC's are also calibrated correctly and all motors spin up evenly and in the correct directions. I would say it takes us about 5 goes on average to throttle up, not taking off level, throttle down, throttle back up, not taking off level, throttle down, etc. etc., until on the fifth go it might take off level.


2. Flight mode: My friend has been flying a DJI Phantom for quite some time now. As he is our main pilot for the octocopter he did most of the test flying. He made a point that the APM 2.5 has no flight mode similar to the Phantom's "GPS Attitude" mode. What the "GPS Attitude mode" does is basically allow the pilot to move the Phantom in any direction, let go of the sticks and the Phantom will then attempt to hold that exact position via GPS. The nearest thing I can see the APM has to this is "Loiter mode" however from what I understand it has a 5m radius deadband so if you enable Loiter mode at 0m fly anywhere to 4.99m it will attempt to go back to the 0m point? Am I understanding "Loiter mode" correctly and if so is there anyway to disable the 5m radius to it will remain at the point each time no input is received from the pilot?

3. We also tried "Alt Hold mode", we enabled it and the copter starting to travel slowly up by itself. I am guessing an adjust in the PIDs is necessary to correct this?

Any help would be greatly appreciated. If there are any experts in Brisbane, QLD Australia, or near to Brisbane, that we would be able to get some help tuning it from it would be brilliant.
Cheers, Cameron

Views: 669

Attachments:

Reply to This

Replies to This Discussion

First thing is to do is post a dataflash log, it really helps.

On point 2 - in 3.0, there is no deadband in loiter. I've never flown anaza, but I think the current loiter mode is similar to the 'GPS Attitude' mode, though I find the 'loiter point' moves faster than the model (so when you let go of the sticks, the model continues on until it catches up to the 'point'). Not tried to tune that out as it doesn't worry me to much.

On point 3 - have you done anything to check vibrations, or set THR_MID?

Thanks for the reply Rick.

I am not sure how to read the data logs or if I have set the APM correctly to read them but it's currently set to default+imu. I am also not sure how to tell which logs correspond to which flights...the flights were on the 13th of July but the log files are labelled the 15th? I have attached what I could find.

Good to hear about no deadband now in loiter mode on the APM 2.5, once we get it tuned a little better we might be a bit more successful with it.

In regards to point 3: no I have not done anything to check vibrations, nor have I set a throttle mid point, it is set on the default 500 in mission planner. I am assuming that is where I might have gone wrong, the THR_MID needs to be set once we have established the throttle position for it to hover?

Thanks for your help :)

Attachments:

Vibrations look to be ok - could be better, but they seem within tolerance.

I'd try setting THR_MID to 700 maybe 750 based on your logs.

How tentative are you being with your lift-off?

Thanks for checking over the logs Rick. I will look at adding a bit more vibration protection to the octo/apm.

Thanks for the suggestion on the throttle mid, I'll set it and give it another go.

With the take off we have tried a number of ways to get it to lift without tilting...increasing the throttle slowly until it started to lift which most of the time ended up in it leaning over too far before it got completely off the ground, giving it a far amount of throttle which caused it to lean too rapidly to one side and was the reason why we broke a prop, and by counteracting the lean by using opposite stick whilst applying throttle. None of the ways were particularly successful.

Possibly part of the problem is the fact you're underpower (given that THR_MID needs to be increased). The THR_MID on my hexacopter with gimbal is 360. So I could imagine that there's less headroom to provide life and attitude correction on your setup.

Maybe turn on MOTORS logging and try again - so we can see what is going on there...

I'm having the same issue. Can't lift off vertically. After switching from APM to DJI I returned to APM again on version 2.9.1. After upgrade to 3.0 I can't get the copter of the ground anymore. On my quadframe in x configuration the back-left motor always stays behind resulting in flipping. Compassmot is 10% and vibrations are well under control. V1 board is mounted on earplugs. Did ESC calibration again but no result. Any ideas for further testing would be helpfull.
Jan

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service