So my custom built hexacopter crashed during an autopilot flight. This was after two successful autopilot missions on the same day. Everything seemed to be working fine. I am running a pixhawk with 3.3? firmware I think (I updated it about 2 weeks ago). Missions were planned and executed on a Nexus 7 tablet with 3DR telemetry. I never touched the transmitter.

Checking the bin file, the only odd thing I noticed was a change in the throttle input on the "Battery Issues" plot. I never touched the throttle. I did lose the telemetry signal during all of the missions, but it didn't affect anything on the other two flights. Also there were changes to Loiter and Stabilize modes that I never initiated.

Here is a video of the crash. Note the beeps just before the crash.
https://youtu.be/m_m7VjQ1IeI

The pic from DroneShare is odd too. Not sure why home is all the way to the right. I powered up and armed at waypoint 1. All that was on my tablet were the 8 waypoints.

There was wifi being broadcast all over the island. Any chance the wifi overwhelmed my transmitter and killed the mission? Any help would be appreciated. Not sure if this was a fluke occurrence or if there is a problem with my hex. The damage was minimal although we almost lost the thing in the vegetation. Luckily the hex was still powered and we could use the telemetry signal to find it.

Views: 56

Attachments:

Reply to This

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service