Hi,

Hopefully you can help me diagnose what I believe to be a failed ATMEGA32U2 chip on my APM 2.0 based on the following diagnosis.

  1. PC no longer makes a beep when connected via USB and extra COM port is not found.
  2. RX and TX leds no longer flash on the board
  3. Receiver inputs no longer control the servo's (PPM encoder not working ? i.e. 32U2 chip)
  4. Attempting to update the 32U2 firmware (thought it may have become corrupt) fails. PC still doesn’t see APM 2.0 following reset of 32U2 and hence unable to flash.
This was the procedure I followed to try and see if I could reflash the 32U2.
 

The rest of the board seems to be fine as the blue/red/yellow LEDs flash as normal and the servos centre after about 5 seconds following switch on.

Anybody any ideas on what else I can check or do you agree that the 32U2 chip is dead ?

Many thanks

Views: 696

Reply to This

Replies to This Discussion

I had a light crash yesterday, (no props broken and no physical damage to the APM2) and mine has the exact same symptoms.

Hi Arashi,

Who did you purchase it from and are they classing it as faulty needing to be replaced ?

Thanks

I bought it from 3dr.

I just sent them an email yesterday asking about repairs, so I don't know yet.

I really want to see the logs.  The esc's were beeping when I picked it up, so they weren't getting any signal from the APM2.  Everything was still properly connected and intact, so they shouldn't have been beeping.

Now I am wondering if it failed in flight causing the crash.  I was FPV at the time and it just lost all thrust.  I watched it land in a bush.

Many thanks for the info Arashi

I have found on my board the same symptoms and have put it down to loose connection of the mini usb cable, as sometimes it works and sometimes it doesnt, it requires moving around slightly until it connects and then dont even look at it or it disconnects again. The board is new and never crashed and I have tried a different usb cable and have the same problem.

We had a similar problem. Completely unable to load firmware "error cannot detect APM version". Initially we thought it was a bootloaders problem
It turned out that a component (cannot remember which) had fallen off in shipping

@ Dean - I've tried 3 different usb cables and 2 different computers to no avail.  I did the "wiggle" the connector thing too, with no success.

@TFS -  I looked it over very carefully under a magnifying glass.  I found no visible damage or missing components.  The only place I can't see fully is under the attached shield.  Might you recall what part fell off?

I was never told. I sent it back and I was told that a component had fallen off

Then I feel you could be right and there is a problem with your board?

Well, 3dr got back to me said they don't have a repair service, and that my 32u2 or mux must have been damaged in the crash.   I serious doubt that.

Is there a way to reflash teh 32u2 chip to try and get USB connectivity back? Isn't the USB (FTDI) function in code on the APM2 rather than a separate FTDI chip?

Is there way, other than the telemetry port or USB to talk to the thing?

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service