I did 3 flights with my quad this morning and the first flight went flawlessly.  On the second one, the quad suddenly yawed about 45 degrees really fast to the left.  I thought it was the wind or a fluke, so I brought it down (with a hard landing) then fired it up again.  Same thing happened about 2 minutes into the flight, suddenly yawed really fast at about 45 degrees and starting drifting away from me but I recovered and brought it down safely.  (my piloting skills are getting better) .  

 

I was flying in stable mode the entire time, I'm on 2.0.33, with gps, and no magnetometer.  Why would this have occured? Could it be a faulty motor or ESC?  I checked all connection and found everything to be secure.  

 

 

 

Views: 118

Reply to This

Replies to This Discussion

I have a very similar issue. My original post is here http://www.diydrones.com/forum/topics/2024-beta-crazy-yaw?xg_source...
Unfortunatly I have not found a solution.
Mine will rotate 90* at a time.
Things I have tried

Balanced the blades. (A nice improvement in vibration)
Soldered the filters on the IMU
Isolated the IMU/APM with several strips of 3M tape
New Battery
Moved the Receiver (away from the ECS's)
Loaded the latest code 2.0.33 at the time

The last time out it rotated a full 360. Hit the High Desert pumice sand (fully pilot error, duh) and filled the motors with metalic material --- FYI don't ever do that.. you will spend the next hour or two cleaning out the motors.

I plan on dropping the GPS on the next flight to see if that corrects it. If not... I guess I start the shot gun troubleshooting method and replace the IMU, GPS, and APM one at a time.

If this is a hardware failure can someone suggest what part would most likely cause this behavior. I'm hoping that a suggestion can save me a few hundred bucks.
I don't think it is a hardware failure as I noticed this behavior started when I updated the firmware to AC 33. Fortunately I was in testing mode so all the props were off and I was watching the radio monitoring window in Mission Planner. Mode was set to Stabilize. When I set the throttle to 50% the motor outputs are indicating a slight yaw. After about a minute there is a sudden large yaw output. If I lift the quad up and rotate it to match were it wants to go it settles down. Not long after that it does it again without any yaw input from the radio (as far as I could tell).

Another thing I noticed is that any small amounts of yaw input produce significant yaw outputs on the motors (audible and visible on screen on the radio monitoring window).

So possibly the new AC code is set to overreact to small yaw inputs and when you a playing with the throttle stick you are actually nudging the yaw by small amounts?

Note, I don't have a magnetometer installed, just the GPS and it did not have lock. In Stabilize mode that should not have any input on the motors.

I have the same problem with beta 33. I was hovering gently, and all of a sudden the quad yawed quickly some 180 degrees or so. This happened twice (!).

 

Yawing 180° suddenly is usually caused by the quad finding a shorter route to the desired Yaw angle. So say you are holding 0° and your copter has turned to 188° because of wind, ESCs that are not calibrated, or tilted motors. The shortest route is to go 172° CW to reach 0° again. Because the quad wanted to go CW to begin with, it rockets around CW to get to 0°.

 

This is mostly a hardware issue with the quad setup not balancing the output of the counter rotating thrust.

Jason

So your suggestion is to re-calibrate the ESC or see if our motors are tilted and correct that?  Would unbalanced props cause that also?

Thanks. Two questions:

 

1) Will miscalibrated or tilted motors manifest itself somehow in the logs? I can't see any tilting, and I have calibrated the ESCs -- but I have upgraded the firmware and erased the eeprom after that. Should I re-calibrate ESCs?

 

2) One of my propellers is a little looser than the others on the shaft. Can the propeller slip on the shaft and cause this?

i had this exact issue yesterday i would fly aggressivly and bang turns 45 degrees
wat i did was.

i thought it was the compass and disabled that, wasnt it.

so i disconnected the the gps (not disabled) and it flys great full stable no sudden yaw.
i dont know wat it is. but i worked out how to stop it for me.

for me, too! I diconnected the gps and now it works without this yaw issue in stabel mode!

 

So do I have to replace the gps?

 

Thanks,

Michal

Jason --- my quad makes the yaw correction well before it has had a chance to drift. It happens within the first 30 seconds of flight on a fairly consistent basis. I'm not flying agressive nor sending any yaw changes from the transmitter (at least not to my knowledge)
In stabilize mode without a mag -- is the heading a calculation only from the accelerometers? or is the GPS used?

Hello!

 

I'a m new here, maybe somebody could help!

 

have the same problem running 2.0.33, compass disabled. hexa with 20-22l Motors and turningy escs, 1045 propellers.

...suddenly it starts yawing!

 

did all the homework: esc recalibration, etc.

 

Can somebody share pids for similar frame (55cm, hexa, 1,6 kg with battery) to sort out wrong pid settings as a cause.

 

Thanks a lot!

Michael

Please upgrade to the latest code (you're two versions behind) and try again.

did that today, an hour ago with the new mission planner.

 

the hexa flies smooth on pitch and roll with standard pids, but has the same "sudden yaw issue" .

(stable mode)

 

- shoud I change yaw pids for hexa (55cm; 1,6kg; 6x20-22l, 3s)?

- should I change motors, escs?

Thanks,

Michael

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service