i've been trying to get the new beta uploaded but always get the same error on compile.

copied the new libraries over but no help.

 

D:\_Quadcopter\arduino-0022\libraries\AP_RangeFinder\AP_RangeFinder_MaxsonarLV.cpp: In constructor 'AP_RangeFinder_MaxsonarLV::AP_RangeFinder_MaxsonarLV()':

D:\_Quadcopter\arduino-0022\libraries\AP_RangeFinder\AP_RangeFinder_MaxsonarLV.cpp:34: error: no matching function for call to 'RangeFinder::RangeFinder()'

D:\_Quadcopter\arduino-0022\libraries\AP_RangeFinder\/RangeFinder.h:30: note: candidates are: RangeFinder::RangeFinder(AP_ADC*, ModeFilter*)

D:\_Quadcopter\arduino-0022\libraries\AP_RangeFinder\/RangeFinder.h:27: note:                 RangeFinder::RangeFinder(const RangeFinder&)

Views: 93

Reply to This

Replies to This Discussion

Which code are you using? The latest in the repository compiles fine for me. I've posted a zip if you're having trouble pulling from Git.

Looks like your libraries are not in the correct spot. Make sure you specify the library path to right folder. Then Restart Arduino to rescan your new Library folder.

Jason

somehow fubared my libraries, so just reinstalled arduino and 2.0.46 seems to be compiling just fine now. thanks for confirming it was a libraries issue,

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service