I did a first test with RTL on 2.5.3 today. After GPS fix I took off ans steered the copter away from me in STAB mode. Went to RTL mode and watched the copter reaction. Instead of coming back he continued to move away. Does anybody has an idea that could help! Was doing the test with another ardufan. Had the same version and it all went OK on his copter. Very strange.
Any help is highly appriciated.

Jan

Views: 737

Reply to This

Replies to This Discussion

I can concur. I was the ardufan ;-).

First attempt we waited for 3D fix before arming. The wiki mentions this.

Then lifted off and flew a couple of metres and switched to RTL.The quad went left forward in the other direction from where we armed.

To make sure we turned 180 degrees and did the same test. Again it flew left forward.

Next, with MP we manualy entered the home position and redid the test. Same result. Can't figure this one out.

Please post the logs. 

Chris,

See logs attached. Hopefully it can shed some light on the issue.

Jan

Attachments:

Very Curious as well.  I have tried RTL via channel 7 a few times.  In all cases waited for a blue GPS lock, armed motors an few straight ahead about 100 feet in the same direction.  Hit RTL and quad did anything but fly straight back as expected.  It went right one time, left, away ect.. nothing predictable.  Furthermore its unpredictability was a quite a high rate of speed which was fun to wrestle with :)

I will try again as I just figured out how to get logging working and see if the results are similar. (My dataflash card was giving me a problem).

I had this happen in the very early days.

Have you verified the magnometer is working correctly.

In my case it was not and the quad just flew away.

Luckily it hit a tree before it got too far.

Also make sure you have got a solid red light on the oilpan, not just solid blue on the gps.

By the way the magnometer is my most troublesome piece of equipment.

Lloyd,

Will surely check the solid red light on the oilpan next time. That's easy.

Do you have a quick check for the magnometer? How to quickly check it?

Jan

Lloyd,
Can now confirm that the red LED on the oilpan is not my solution. Indeed, it takes quite some time for the LED on the oilpan to become solid after the GPS LED is solid. But the problem is still the same when testing. Did some testing in the garden today with the copter in my hand. When switching to RTL (away from launch position), the copter only wanted to fly in the wrong direction!
Happy that I didn't lost my baby yet.
Jan

Jan,

      Good idea about the hand-test.  I did that with my tradHeli when I was first trying loiter.

      You probably saw my other post to Doug 2 minutes ago but I think you also don't have a mag?  Or maybe it hasn't been enabled in the APMissionPlanner's Firmware, APMSetup, Hardware Options screen?  It should be enabled by default but when I look at your logs i see a zero mag number.

     The way to see this is to open up the APMissionPlanner, push the Terminal button on the top right.  Then click the "Log Browse" button, then select the file you posted above.  Then find an ATT line (first column), and then scroll over to the Mag Heading column and click the "Graph this button" button...you'll see it's a flat line.

     This is what it shoudl look like.  It's a bit insane looking but that's the compass heading * 100.

 

Randy,

I have a mag for sure and when doing the setup in MP I always check that it is selected. However, I'm not sure if it working correctly. Never checked this. Copter does what it has to do in STAB and that made me happy in the past. Now it's a different game. Will check for sure.
Thanks for your advice,
Jan

Thanks Lloyd.  I can confirm my mag is working, at least without the motors running.  My problems are occurring with APM2.

I've engaged the RTL on my Hex a couple of times and watched as it took off due north and down with the RTL point set due west.  I had GPS lock for nearly 2 minutes, armed and flew east and up probably 100 meters each and engaged RTL to watch it make a mad dash for some very tall trees to the north. I let it go for what seemed like a long time, just to see if it would correct and just prior to smashing into the trees I switched back to stab mode and recovered the Hex maybe 30 feet short of the tree line.  I probably came down 50 meters and went north 75 meters.  After this I landed, disarmed, disconnected the battery and fired it all back up and tried again, with nearly the same result.( I decided to abort the RTL much sooner on the second attempt). 

I don't have a magnetometer, is one required for RTL?  Are there some PID settings that will slow the pace of the mad dash of RTL so that I can do further testing at a lower risk of crash?

 

Thanks,

Doug

 

Doug,

Same exact questions and experiences here.  I have attempted to change the m/s setting in the Nav WP section on the configuration tab.  That did not change the rate in which my copter decided to fly in upon engagement of RTL.  I am glad I am not the only one experiencing these problems.  My Loiter works great and the copter flies great... but before I attempt any autonomous missions I want RTL to work.

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service