A few comments on how to make the wiki clearer on how to set up Failsafe, and a question on how to test it. Extract from the wiki with my comments:

 

If you have enabled failsafe (how? I have set my config THR_FAILSAFE to 1 - is that correct?), your copter will RTL back to home, and auto-land after 20 seconds.

To enter failsafe, you must be armed (failsafe does not work when disarmed) and you must set your receiver to output a low throttle signal (below 975µs by default). To send a throttle value that is below your radio's normal neutral throttle value (say 1100), please read your radio's programming manual.

I would make this a bit clearer. For instance, "you must set your receiver to output a low throttle signal (below 975µs by default). This can be done by looking at the Status or Raw Sensor View (Radio) and changing the end point on your low throttle setting so that it is below 975µs. Then programme that into your receiver as a Failsafe setting (refer to your receiver's manual). Then reset your low throttle setting back to what it was e.g. 1100. Test that the receiver Failsafe setting is working by viewing the radio data as above and then switching off your Tx. The Ch 3 setting should now drop to the below 975µs setting. Switching the Tx back on should restore the Ch 3 setting to your normal neutral throttle value. Recalibrate your radio settings once you have completed this exercise.


How do I safely test that this will work? I tried taking my copter outside, powering it up, getting a GPS lock and then arming it and looking in Mission Planner. I could see Ch3 in reducing to 965 when I turned my Tx off, but there was no indication of a change in mode. Oddly enough, I am reluctant to turn my Tx off when I am flying it.

Any guidance on this would be much appreciated as I would like to have this safety feature as insurance to help prevent injury (and crashes and money!).

Regards, Bill

Tags: Failsafe

Views: 4219

Reply to This

Replies to This Discussion

Hi Roger,

I used APM2 board with AC2.4.1 (GIT 28feb) and a JR/Spectrum DSM2 RX.

Yes, set THR_FAILSAFE to 1.

But before it will work you have to program your RC receiver to output less than 975us on the trottle channel in case of lost signal. Refer to the failsafe wiki for that. Note that it still seems to give incorrect information on THR_FAILSAFE_ACTION, read the comments under the wiki page.

I did hand tests before actually flying and turning off the TX.

I know Tomas, open new issue about this, also for "ALT_HOLD_RTL" (disabled in the code).

oops wrong thread can someone please delete this.....

I'm having trouble understanding how to set the ch3 output to go as low as 950.

I'm using a turnigy 9x with frsky module, and currently I have the frsky receiver failsafe set to about 50% throttle and it will switch it into RTL using the ch5 mode switch.

I don't feel particularly confident in this, as I just tested this on the bench with no props (and no gps lock) while the quad was armed by turning off the transmitter, and the motors went to 50% throttle (as expected).

It sounds like the better method would be to set the receiver to output less than 975 on ch3 as discussed here, but I don't understand how this can be done with my radio. Anyone know?

Hi Glen connect to your MP APM and go to setup radio and use your end point adjustment in your menu on the radio to set below 975 hit menu then go to fail safe set up in the radio and set throttle FS and push and hold menu button for 2 seconds or until it beeps and your set . now go back to your endpoints and set to 1000 you may have to set other switches not sure

Cheers yeah I did it by going into the Epoint menu on the trasmitter, setting the down point to 120% which equates to 983, hit the failsafe button on the receiver, then set the down endpoint back to 100%. Then in MP set my THR_FAILSAFE to 1, THR_FS_ACTION to 2 and THR_FS_VALUE to 990.

In MP if I turn the transmitter off I can see the ch3 value drop to 983.

What's the best way to test this will work in practice with the minimum risk of destruction?

you should see the mode change in MP ,,you might have to set your home away from you actual location. you quad guys have got a tough time with testing it seems . good luck

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service