Hello all,
I finally learned that my problem with the binding issue was that I wasn't removing the bind plug, and that was therefore putting the receiver in bind mode every time after I restarted the quad, so that's out of the way. Now that the Rx/Tx are communicating properly, I have learned that my problem now is with the Rx/FC connections, or lack thereof. I'm using the Turnigy 2.4GHz 8ch PPM receiver and a Pixhawk, and connecting them with the Hobbypower V2.0 PPM encoder.

The right side, with one wire, connects into the "RC in" port in the Pixhawk servo rail, while the side with multiple wires connects into the receiver, one wire for each channel on the receiver. Channel one has three wires. The red one is for power, the black for ground, and the white for the channel itself, so the receiver receives power.

The thing is, when I open Mission Planner to setup the Pixhawk, and I get to Step 10, the Radio Endpoint calibration, it doesn't appear to be bound! Is there any way I can test the flight controller to make sure it is getting its signals properly? The channel wires in the receiver aren't broken and they are all in the correct ports. Nothing seems to be out of place, but the flight controller still isn't getting what the receiver is trying to tell it, and is in turn not giving it to the computer. If anybody could help me fix this issue and move on to the first step, I would probably be forever in your debt.

Also, the Pixhawk keeps telling me that I haven't set up the failsafe feature of Mission Planner, but as my transmitter came with a scant instructions manual, I'm almost positive it didn't come with that feature, so I need to disable it somehow, but I can't figure out how. If I absolutely have to set up the radio failsafe and it doesn't have to do with the RC gear and more the flight computer, could you please tell me how to set it up? Thank you, if you can answer that, too!

Views: 120

Reply to This

Replies to This Discussion

Update: I got past step 10, it turns out my RC wasn't calibrated. The firmware was uploaded properly, and the failsafe was also set up without issue. This isn't necessarily an issue, but more of a space saving question. Is the External GPS mandatory, or can I leave it off? If it's mandatory, am I allowed to attach it to the bottom of the quad, upside down? Also, how do I calibrate the compass without using the setup wizard? Thanks!

So it seems as soon as I posted that reply, I figured out how to fix the yaw issue and now I have a new issue: The safety prearm checks. Here's what it says

PreArm: Accelerometers calibrated requires reboot
PreArm: GPS HDOP 5.2 (needs 2.5)
PreArm: inconsistent compasses
PreArm: RC not calibrated
PreArm: Waiting for Nav Checks

Those five keep popping up over and over. First, I already rebooted both Mission Planner and the quad. Second, I don't know where I can change the GPS HDOP value, so if anybody can tell me where, that would be greatly appreciated. Third, I don't know what it means by inconsistent. What about the compasses is inconsistent? Fourth, I already calibrated the RC, three times. And fifth, I don't know what Nav Checks are. So can someone please tell me how to get past these problems? Thanks!

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service