Hi all, first post, hope it's in the right section..

I'm currently trying to setup failsafe arducopter v2.3 and turnigy 9x v2 but I'm now stuck...

I set thr_failsafe = 1 and thr_fs_action = 2

I suppose that the failsafe function is enabled when all channel send 0-975 signal or the radio is swicthed off. 

Well, for what I'm seeing the original receiver of the turnigy 9x in PPM sends to the arducopter the last signal received. i.e. throttle at 60% and stays there,  unless you haven't enabled the failsafe function in the radio menu. But, as stated in the manual, it works only in PCM mode ( as far as I understand this is valid for other radios, too).

If I enable PCM mode, all the channells get crazy... throttle included... (no props attached!)

I'm pretty sure I'm missing something... if anyone can help it would be appreciated,

thanks

Views: 11725

Reply to This

Replies to This Discussion

As fat as I understand the failsafe in T9X is only working for PCM, and not PPM that the 2.4 GHZ modules uses, and as such not available.

Thanks Geir,

so you're saying that there's no way to make 9x standard tx-rx module work in PCM and consequently to make work both failsafe for rx and arducopter.

But i.e. with a frsky tx-rx module, PCM can be enabled and so failsafe channels values and failsafe on ardu... Did I get it right?

Thanks again!

I just setup my FrSky module for my Turnigy 9x and successfully flew / tested failsafe. What I ordered:

http://www.hobbyking.com/hobbyking/store/uh_viewItem.asp?idProduct=...

The 9x transmitter actually stays in PPM mode. The FrSky receiver has a button to program the channel output when connection is lost. Set sticks and switches on remote, then push button on receiver. After that the receiver will deliver the signals if remote is turned off or connection is lost. But it's smart enough to not go into failsafe if the receiver is powered on before the transmitter.

thanks Andreas, I'm going to include this in my next order.

in order to activate failsafe on the arducopter which channels values do you set in the FrSky receiver?

What I set for my plane:

Right stick neutral

Left stick 50% Throttle

Mode switches: RTL

For Arducopter it might make sense to also use RTL or Auto-Land mode.

Thanks very useful! 

I'll do without failsafe until I get a new receiver and will limit the risks flying in line of sight and with full battery...

any pictures on how you did the switch in your 9X?  That would make a good wiki... 

Adding the FrSky module is only a matter of plugging it in. Preserving the 9x module is another story as the antenna cable can't be unplugged.

I essentially did the same procedure as posted in the link below. The only tricky part was to reconnect the miniature coax antenna cable of the 9x module. Have not done any range tests, but so far it looks like it survived the operation.

http://azureengineering.blogspot.com/2011/02/turnigy-9x-transmitter...

Please can I ask what you guys think of THIS motor.

Thank You

wrong section sorry...

I am having a problem with a Turnigy 9xBC version 2 RX when there is an absent of a signal from the trnsmitter(turned off), it output the last value received from the TX signal on Channels 4 and 5.  I have gone into the transmitter setup, switched to PCM and tried to disable any failsafe setting there but the RX but it still outputs a signal on channels 4 and 5 regardless.  This is not good for the simple Servo to PPM encoder that I would like to use.

Stock Turnigy 9X with the stock 9X8Cv2 receiver has got a configurable failsafe for signal loss. 

-Set the transmitter to PPM in SYSTEM SETTINGS->MODEUAT/MODULATION->PPM 

-Set FUNC SETTING->E.POINT->THROTTLE to 120%/120% (This changes the maximum throw up&down. protip: move throttle stick to change value for up/down...)

-Set FUNC SETTING->SUBTRIM->THROTTLE to -120 (sets the midpoint lower, so that the failsafe value goes to less than 1000

-Set FUNC SETTING->FAIL SAF->THR->F/S 000% (This sets the failsafe (transmitter off) value to 0%, which goes -to <1000 since we changed the midpoint/endpoints. In my system, the failsafe value is 900 and min throttle 981.

-Adjust your throttle trim and APM/multiwii/etc. failsafe thresholds so that the failsafe signal value is lower & failsafe is correctly activated in your autopilot. Poke, Test, poke and test. Don't rely on the default values!

Note: My Turnigy transmitter&receiver are a few years old from Hobby King. Your results may vary. Tested on [SYSTEM SETTINGS->TYPE SELECT->ACRO] model type. Not sure if everything are the same for GLIDE&HELI. Also the Turnigy is a cheap-ass system, consider something better for anything valuable&dangerous. :)

Some pics of menus: https://www.dropbox.com/sc/9qmdbg1m1fqkmvy/PNpV77VN0n 

Reply to Discussion

RSS

© 2016   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service