Arducopter is limiting the total power output of my hexacopter to 37 amps when it has the potential for 66amps when at full throttle.

I bench tested many different motor and prop combinations to see which would be the most efficient for my arducopter hex 550.

I decided to use 6 x 1000kv motors with 9x4.7 props which deliver 710g of thrust at 11amps each at max throttle.

Why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.  (see mission planner tuning chart)

I understand that the controller needs reserve power for controlling stablization but 37 amps is only 56% of total power potential that could be used.

I have calibrated my escs many times thinking that was the problem but its not.

When i use my kk2 controller on the same hexacopter i get 52 amp draw at max throttle held down on the bench.

Is there a setting that i need to change to allow the controller to use more potential power.

I want to put more equipment on this craft but it needs more power.

Thanks in advance for your help.

the Chart below shows thrust output for each motor/ prop combination.

I decided to use a 1000kv motor with a 9x 4.7 prop. next chart

This chart is just the 1000 kv motor with 9x4.7 prop  

max thrust was 710 grams at 11amps

I went into the tuning page for Misson planner and see that at full throttle i am only drawing 37 amps for 6 motors.  Hexacopter held down at full throttle on the bench while connected to MP.  the hex draws about 25 amps at hover with no extra equipment on board.

why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.

I understand that the controller needs reserve power for controlling stablization but that is only 56% of total power potential that could be used.

Is there a setting that i need to change to allow the controller to use more potential power.

Views: 18115

Attachments:

Reply to This

Replies to This Discussion

I ran into the same issue with APM 3.2. After reading through all available forums I think I found the resolution to this problem.

First, check the PWM input value for Channel 3 and compare it to the output values for Ch1-4 in the status monitor. In my case, Ch1-4 out never exceeded 1500, regardless of the Ch3 input.

Apparently in some installations 2 parameter are set to wrong values, THR_MAX and MOT_TCRV_MAXPCT.

In my case, THR_MAX was preset to 80 (default is 800 -1000) . Resolution: set this value to 1000

Aso in my case MOT_TCRV_MAXPCT was set to 40 (range 0-80). This limits throttle to 50%. I set this value to 80 and suddenly had full power.

Re-check Ch1-4 out at full throttle. Now you should read a PWM value of ~1900 and you should be good.

 

I am still interested why those values are set up wrongly in some installations......

I am using APM 3.2, but had the same issue with APM 3.1.5

Thank you for this post. The MOT_TCRV_MAXPCT I've never hear about before. Mine was set to 93 when it clearly says in the parameter list the highest is as you say 80. Changed it now and will se if it makes any difference. =)

My previouse solution has been to calibrate the ESC's from TX at 1900 PPM max value.

Throttle curve was made to try linearize ESC output, that usually has it's last 7-10% output same value.

Instead of changing MOT_TCRV_MAXPCT to 80 (default is 93) try disabling throttle curve by setting MOT_TCRV_ENABLE to 0.

Emile

Okej, thanx for the tip. But why is the default value 93 if the range is only up to 80? Would there be any difference between 93 to 80 or does 93 get interpreted some other way?

Because on bench tests the majority of escs was at full throttle with 97% of the maximum PWM.

So the throttle curve tries to linearize this curve and give full PWM at 93% of throttle.

Throttle curve does this to find the maximum PWM:

int16_t max_thrust_pwm = radio_min + (float)(radio_max - radio_min) * ((float)_throttle_curve_max/100.0f);

where throttle curve max is the parameter : MOT_TCRV_MAXPCT

and radio_min and radio_max are your radio calibrated parameters.

P.S.

MOT_TRCV_MAXPCT range is 50-100....
If not update your mission planner to get the latest oparameters defaults.

// @Param: TCRV_MAXPCT
// @DisplayName: Thrust Curve max thrust percentage
// @Description: Set to the lowest pwm position that produces the maximum thrust of the motors. Most motors produce maximum thrust below the maximum pwm value that they accept.
// @User: Advanced
// @Units: percent
// @Range: 50 100
// @Increment: 1

okaj, that was a good explanation. Nice to see the code as well.

But from there. Should not the APM calibrate the motors accordingly to its maximum output? 

Hi there,


We're getting the same problem using an contra rotating motor on Arducopter 3.2.1, powered my APM 2. When using calibrating mode for the ESC's, the motor get full power and seems able to rise. On the other hand, when trying to fly the UAV using the CoaxCopter firmware, motors doesn't get full throttle and barely try to climb. Have anybody solv'd that?

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service