Hello guys,

I am building an FPV plane at the moment and want to do crop scouting with it. So I want to use telemtry to upload waypoints and edit the mission etc.

I installed the recent ArduPlane fw (V3.5.2) and calibrated the mandatory hardware. I bought a pair of XBEE Pro 868 MHz modules with RP-SMA connector and set them up via XCTU software.

I set them up with following settings:

Modem VID: 105

Destination Adress high: 0

Destination Adress low: FFFF

Baud Rate: 57600

API off

The Groundstation is set up to Coordinator Enable: Coordinator

The Air end is set up to Coordinator Enable: End device

I can send messages from one XBEE (linked to an Arduino as I have only one SF USB explorer) to the one connected to the PC via SF USB explorer regulated. The board on the air end is an SF explorer regulated board. I see the messages in the XCTU terminal, so the connection seems to be fine.

On the pixhawk side, I wired the explorer board as mentionend on the ardupilor-website (http://ardupilot.org/copter/docs/common-telemetry-xbee.html#common-...)

Connecting from Mission Planner to pixhawk via USB is no problem. But when I try to connect to pixhawk via XBEE, I see both RSSI-LEDs come on and the RX-LED on the PC-end blinks and also an the air-end you can see the DOUT Led blinks, but Mission Planner always says "No heartbeat" (COM port is selected and baud is set to 57k).

After a few days I was very frustrated that I couln't get it to work so I decided to buy a pair of XBEE Pro S2B 63mW modules to hopefully fix the problem. But it tis still the same.

Both XBEEs are configured and can talk to each other. One is coordinator, the other is end-device.

Does someone have or had the same problem? I have no idea what else I could try to get telemetry to work.

Thanks in advance for your help!

Views: 976

Reply to This

Replies to This Discussion

Is there nobody, who has an idea how to solve this problem?

I Have the same issue.  Worked fine on APM.  Works fine USB to USB.  As soon as I connect pixhawk to xbee, very dodgy.

The odd hearbeat comes through but that's it.

Scoped the pins coming out of pixhawk, can see the hearbeat, looks ok.  Scoping the RX on pixhawk shows a bit of noise each time a packet is send from the GS but certainly not pulling to ground.

Stuck scratching my head thinking it is the Xbee breakout board....

Good to see that I am not the only one having trouble to connect the XBee.

I thought the same with the Xbee breakout board. Is there an alternative to that board?

Hey there, Same problem!

I tried interfacing with Arduino but that works just fine but as soon as I get back to Pixhawk, it doesn't connect> I even tried with the PX4 flight stack in QGroundControl; still the same.. no connection.

Seriously and desperately looking for help.. getting frustrated day by day and stuck at the same problem

Why did you choose XBees? Thats very old school.

Been doing this years, have loads of them lying around and they weren't cheap!

The Xbee 868 has a low data rate, 24Kbps, & if you enable AES encription I believe it will be reduced further.

If the telemetry serial data rate is greater than the radios' RF transmition data rate there will be lost data.

Maybe try reducing the telemetry rates in Mission Planner Config> Planner_Tab to see that helps the data flow.

I have several of the early versions of the Xbee900-pro radios, & although they worked really well with the APM 1 & 2 autopilots for ranges of several Km's with crappy 1/4 wave wire antennas, they seemed to have poorer performance ( more lost packets)  when I used them with the Pixhawk, even with good quality antennas.  It turned out that one of my radio modules was a little different.

I discovered this when I tried to switch the radio firmware from DP (Digi-point)  to DM (Digi-mesh) and one of the radios would not accept the newer firmware.

The Digi-mesh firmware did improve (reduce) the error rate.

Also I tried to use the CTS + RTS pins for hardware flow control to improve the data handling as well as changing the Xbee's packet threshold but there was much , if any , further improvement.

My tests consumed countless hours , but, they were not conducted in a completely scientific manner so the are other factors that have not been accounted for...

I have found that the  3DR  &  RF Design radios (RFD900) do seem to have better performance in general than the Xbee radio's that I have used. [ at least in bench tests and out to 500 meters LOS ].

Unlike the Xbee radios however, the other two do not have legitimate agency approvals and have no security & very  limited  network addressing (two digits).

I've been flying normal R/C planes mostly for the last 8 months or so  &  I don't have any notes to refer to my radio testing.



I am having the same problem, and have spent quite a few hours trying to troubleshoot the issue. For my application, I need a long range radio and purchased two 250mW XBee-PRO-900s with RPSMA connector and 3dBi antenna. When connected to two different laptops (through FTDI-USB convertor) they work. One connected to Particle Photon, programmed to echo the packet back, works. But with one of the XBEE's connected to Pixhawk Telem-1 port, the APM Planner or QGroundControl on my Mac never see the heartbeat messages. Today I am going to rig the XBEE connections to Pixhawk through a mini PCB and attach a logic analyzer to check for the activity on TX and RX lines from/to the Telem port. WIll let you know if I find anything, but if someone here has a clue, please post. Some articles suggest not connecting RTS/CTS pins on Pixhawk to XBEE, and that is how I am operating it (i.e. RTS/CTS flow control turned off on the Pixhawk Telem-1 port and RTS/CTS wires not connected).


Hi Aakash!

I'm facing the exact same problem! When I try to connect 2 XBees through 2 differect PCs via Arduino, they communicate; but the moment I connect them to Pixhawk Telem1/Telem2 (I tried both ports) they just talk (I guess, as the Tx & Rx on both start blinking) but it doesnt connect me to the GCS (tried with APM as well as PX4 firmwares on Mission Planner & QGC). I'm stuck for about 15 days now! Many people around have successfully connected Pixhawk I guess via XBess. Will really appreciate some help.

The second option I think I was thinking of jumping into was to use an onboard PC (like ODROID or R-Pi) and use a Wi-Fi module to communicate. I have to use my system in a MOCAP lab later, so I definitely need this to be done ASAP, one way or another. Any guidance on this will also be grateful



Hi Aakash,

thanks for the info! I'm still stuck with this and use 433 MHz Antennas at the moment. But I would like to use the 868 XBees.
Have you found out something meanwhile?
Where are the guys they already made it and connected a XBee board to Pixhawk?


Hi @Konrad Harbort or others,

Have you able to solve the problem, if so how? Would like to know? I face the same problem between my Pixhawk and QGroundControl (GCS) - same story.



Reply to Discussion


© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service