I am using the following telemetry kit.



I have the right ftdi drivers installed on my laptop. For some strange reason, when i plug the usb adapter into my laptop(running windows 7), around 50% of the time, it recognizes it as a serial mouse.

Very aggravating, because i lose control of my laptop, the mouse pointer gets a life of it's own and finally everything hangs.

I need to restart over and over again, till it decides to work. Has anyone else experienced this? Are there any workarounds?





Views: 983

Reply to This

Replies to This Discussion

I have the same problem. I didn't find a solution to it but the following reliefs the pain a bit:

1) open the windows device manager

2) open the "Mice and other pointing devices" tree node

3) Plug in the xbee module

4) A second later, the new mouse driver becomes visible. Right click it and chose "uninstall"

You have to be very fast in step 4, i.e. you have to delete the driver before the mouse goes mad.

If someone finds a real solution to this: please share...



Same problem here... i'm gonna try Simon's workaround... those Xbee are driving me crazy...

The only thing i've found is that when plugged to the computer, the port should not be receiving data... if i plug first the computer module and then i turn on the plane module, it works...

Mine running on Win 7 64bit and worked from the off, no problems.

TX on quad power on start mission planner then lastly connect the USB to the Xbee, select the com port and speed then connect, so far works ever time.

Paul, you mean that when you plug the ground xbee module to the USB, the plane module is already transmitting data ? When i do that either it jumps the mouse crazy or it bricks the Xbee...

yeah thats what i do!


Paul, what versions of FTDI drivers are you using ? 2.08.14 or 2.08.17(Beta) ? Thanks.

It used to happen 20% of the time for me. Unfortunately on the flying filed last Saturday it happened 100% of the time and I could not fly with the Xbee link. Also I can't do anything in the device manager as soon as the Xbee is plugged in. Any links to a working solution?

Mark forwarded me a theory and fix from another thread (also described by Colin above). I can confirm that the workaround solves the issue for me.

The theory: If the APM and Xbee are sending data when the PC xbee is plugged in, the com port receives data from the get go and Windows somehow indentifies it as a ball point device.

The workaround:

1) APM/Xbee must be turned off

2) Power PC and plug in Xbee in USB

3) Com port should show up in device manager, ball point device should not (under Mice)

4) Power APM/Xbee

5) done...


I confirm Andreas' solution is working... i've been looking a bit in order to find out really whats going on. The only thing i've got so far is that it's not APM or XBee related, it's recurring though almost all windows versions (from XP to 7), and it happens when you connect any serial device already receiving data just like our case here with Xbee...

Now the real question is WTF was going though their heads to keep including in latest Win 7 x64 versions, drivers of a 20 years old mouse messing up with current devices used on a daily basis ?

This is the mouse, every one still use one of these right ? It rocks with Windows 7 Ultimate !

Maybe this thread offers a solution : http://forums.techarena.in/xp-hardware/716002.htm

I haven't really tried anything yet i'm away and i don't have the PC around.

What a strange USB connector that is ;)

Reply to Discussion


© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service