I have been flying my APM miniTalon succesfully for a long time on AP3.0.1....recently I had to replace the APM and reflash....unfortunately, MP will only load 3.4 firmware....the problem is that with this firmware MAG_ENABLE is not longer maintained during power cycles....everything else is....but MAG_ENABLE is always set to 0 on power down!

I have to dynamically enable the compass on each power up via MAVLINK!

I really would like to go back to my tried and true 3.0.1 or even 2.78b...I really want my compass!

but I see now way (unless I compile it myself, which I cant do) to do this (revert to older firmware) with the current MP...

any help would be appreciated!

Views: 109

Replies to This Discussion

Greetings,

Well, i didnt use APM for a long time now.. and i am not sure what firmware i am on now.

BUT, i saw your thread and hoped this will help,

To enable the MAG_ENABLE you have to set the COMPASS_USE to 1.

Sorry for this silly question, did you save the parameters and then write it when you enable the MAG to 1 ?    ^^

Hope you will find the solution.

By the way see this link in case you didnt:

http://ardupilot.org/plane/docs/parameters.html#mag-enable-enable-c...

Good luck


Yes, use compass is enabled....as I said, everything was working fine on previous releases and I transferred all parameters to new controller....except, of course, reintializing the acc offsets...the compass offsets are the same as before, because it uses an external compass that did not change....

and even if I did not "enable use compass", the MAG_ENABLE bit should have still "stuck" since it allows compass logging without having to use the compass in flight..

I really need to get a hex of Arduplane 3.0.1 somehow!


Nobel0 said:

Greetings,

Well, i didnt use APM for a long time now.. and i am not sure what firmware i am on now.

BUT, i saw your thread and hoped this will help,

To enable the MAG_ENABLE you have to set the COMPASS_USE to 1.

Sorry for this silly question, did you save the parameters and then write it when you enable the MAG to 1 ?    ^^

Hope you will find the solution.

By the way see this link in case you didnt:

http://ardupilot.org/plane/docs/parameters.html#mag-enable-enable-c...

Good luck

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service