Boat: 3-meter trimaran

Motor: 2.5hp Suzuki 4 stroke

Controller: PixHawk

Mapping Speed 14-19kph (4-5m/s)

Fly Away - 

a. During the North / South routes everything seems ok, except the wobbly course

b. When the East / West routes start, it immediately fails to do the short route from #52 to #54, but rather does a full west run to nowhere, then returns to #54, but then skips #56 and #58 and goes straight to #60, BUT NOW THE ROUTE IS IN THE WRONG DIRECTION!

c. Then rather than gpoing to #62, it heads off to #58, and then east to #62.  AT THIS POINT THE MISSION IS DESTROYED, and the costly craft is now LOST AND GOING NOWHERE!

HOW THE HELL DOES THIS HAPPEN?

Every time I go mapping something like this happens, this is not what we are looking for from an 'autonomous' ground control system.

If I am doing something wrong please let me know.

Views: 227

Attachments:

Replies to This Discussion

Best to post in the proper forum http://discuss.ardupilot.org/c/ardurover/arduboat

Second you might want to talk to somebody offering commercial support http://ardupilot.org/ardupilot/docs/common-commercial-support.html

Third your tuning is terrible. The autopilot does not have control of the vessel.

1 - I thought this is the Arduboat User Group

2 - Why would I need commercial support?

3 - Yes it is terrible, hence this thread.

This site was abandoned and support moved tohttp://discuss.ardupilot.org/c/ardurover/arduboat 1 1/2 years ago



John Easton said:

1 - I thought this is the Arduboat User Group

2 - Why would I need commercial support?

3 - Yes it is terrible, hence this thread.

John, Do you have a .bin log of this event?
David

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service