How would you know that your IMU is busted? We sometimes have a wrong readings for the attitude of the helicopter. Do we have a software to test if the IMU has a problem?

Views: 520

Replies to This Discussion

Are you using the resistor dividers for battery monitor ?  If you are and you plug in your battery cable to the resistor divider before you power up your heli that could give you the same response you are having.  If I plug in my battery monitor to the apm where the 4 resistors go i have a very slow attitude response.  Everything else works normal (mag, baro, accels, sonar) but gyros and in mission planner the result is very sloooowwww response to pitch and roll. 

I have to plug in main power first then I plug in battery monitor cable and everything works fine. 

That seemed to do the trick! I guess you're right steven, I tried plugging the batt monitor cable first before powering the apm and that indeed triggered the problematic responses we've been getting. Then I tried powering the apm first then plugging the battery monitor as you've said and it worked flawlessly.

Now could this be the reason why we fried our atmega328p(ppm chip) and our mux chip? because prior to frying them we had the said problematic responses;delayed attitude response, attitude all over the place sometimes even from a slight movement from the imu. 

randy, i tried the adc, and it returned values, so I guess the gyros are fine, at least when i power the apm first before plugging the battery monitor. I'll try to post the video of the attitude of the imu when its going haywire soon.

Also seeing the slow attitude problem from time to time here on Arduplane as well.

It is slow updating even in standalone mode where mavlink is not connected on APM.

Will not stabilse correctly when holding and tilting the model in your hands.

Have been able to get it working with combination of reflash/erase and voltage divider.

Interestingly, I had the slow gyro stuff occur the first time when I had no voltage divider soldered and no cables plugged into the volt div pins ( I hadn't set it up yet ).....

BTW, First post - overall super happy with how it flies ( much better than me ! ) :)

 

For the record, I had a similar problem during my first tryouts of the APC board assembly. But problem dissapeared so I am happy. But I never sorted out what was the problem. Maybe same root as you mention here, the analog input.

Here is a link:http://www.diydrones.com/xn/detail/705844:Comment:677866

Maybe the phenomena now qualifies to be mentioned in the Trouble shooting guide?

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service