I have been using stabilize, wanted to try position hold to see if it will at least stay in my back yard and it wont, it drifts off almost hitting fences and plants.

I know the GPS works well because I fly it waypoints a lot and it works well.

Any reason it wont hold position?

GPS both lights blue.

I can see it moving on its own trying to stay in position, but it wont.

Ed,

Views: 2301

Replies to This Discussion

What code/frame/GPS are you using? And are you using the default params?

I did change the default params a little, Meditek GPS that came with the 2.5 APM, I have Scorpion motors.

Hmmm, I had a similar problem, as the copter would drift away and hold a very big radius from the hold position. Perhaps it's related to the GPS. Have you tried using the uBlox Lea 6 GPS with the same params?

Yaron,

     I think your issue could also be the loiter rate needs to be tuned (reduced) or it could be that your compass declination is off.  both issues show the same symptoms...if loiter rate is too high it tends to keep overshooting the target.  If the compass declination if off then it keeps missing the target because it's confused as to which direction the target is in.

    Still, our auto declination normally gets it right (I've seen a drastic reduction in reports of circling since it was introduced about a year ago) so it's more likely loiter tuning.

Edgar,

     I think your Loiter's Angular Rate Control is too large.  The default is 5.0 which is a good number if you're using the ublox but it's a bit too high for the mediatek.  Please try 2.4.

     If you could post some log files of a loiter that would be a great help in determining what the problem is.  The feature itself definitely works so it's either a tuning issue (most likely) or some other kind of set-up issue.

okay, I will try 2.4.  The craft is down today, LEGO failure :) but it should be back up tonight or tomorrow.  I am using Scorpion motors so they have a lot of power.  I actually tried about 2 and it seemed sluggish but I can try again.

Ed,

Ah sorry, one more thing..once ArduCopter ver 2.9 is out, you should update the firmware on your mediatek to ver 1.9.  It definitely improves position hold because the old firmware only reports position to within 10cm.  the new one gets down to the 1cm.  The Arducopter firmware upgrade and the mediatek firmware upgrade go hand-in-hand though..i.e. you need to be on AC 2.9 to use Mediatek 1.9.

Oh, I did find this but it says 1.6 so I think its old

http://code.google.com/p/ardupilot/wiki/MediaTek

The upgrade instructions for the mediatek are here but you need to be running arducopter 2.9 before it will work.  I.e. AC 2.8.1 doen't support the new mediatek firmware 1.9.

Randy, thanks for the suggestion, but unfortunately it still drifted away.  I tried the Alt Hold and it even had trouble.  From what I read the direction of the GPS does not matter?  I was also thinking about putting my GPS on a pedestal like my N... product is to see if that may help?

Randy, maybe this helps:

 I took off in stabilize mode, it flew pretty good with some drift.

Change to position hold

over about a minute the craft started to "pull" to the left, it was almost like a rubber band, I move it to the right where I wanted it and it "slow" rubber bands back to the left to where I guess it "thinks" it is.

Then I change back to stabilize mode.

the rubber band is gone again with normal gyro drift.

Does that point to anything?

Thanks again for your help

Randy,

This is a video that shows whats happening, really its not holding at all :(

When I brought it back when I let go of the stick it kept coming at us :O

http://www.youtube.com/watch?v=tde4sFmuFDg

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service