Hello everyone,

A couple of minutes ago I tried to fly my quadcopter for the first time. Unfortunately it ended in a nose dive before even taking off. Something I noticed was that when I raised my throttle by a tiny bit (from fully down position), the motors started to spin immediately and speeding up by itself (like it was stuck in a exponential thing), followed by the nose dive. I am using a Pixhawk flight controller. What did I do wrong? 

Views: 497

Replies to This Discussion

what flight mode were you attempting to lift off in?

usually a flip on take-offf attempt is due to your props/motors not spinning in the right direction.

check the rotation, proper prop for that rotation and proper drive # for that motor axis

btdt

ptegler

Sounds a frustrating start but I have been there!

If your props started spinning immediately it could mean the ESC's need calibrating and it may play to redo the radio calibration again. For the nose dive check the motors are plugged into the PH in the correct order and spinning correctly. Redo the wizard setup is a good start. Good luck. 

I was trying to lift off in the "Stabilize" mode.

I will check the direction and the wiring once again to verify it is correct.

Do you have an explanation for the throttle speeding up?

Paul Tegler said:

what flight mode were you attempting to lift off in?

usually a flip on take-offf attempt is due to your props/motors not spinning in the right direction.

check the rotation, proper prop for that rotation and proper drive # for that motor axis

btdt

ptegler

Yes.. it is! I was super excited and then my quadcopter did a nose dive which resulted in trimmed off props! :(

The weird thing is the exponential like rate at which the throttle increases, does this have something to do with the hover settings? I will redo the ESC and radio calibration one again, hopefully it will work this time. Maybe I am making a mistake. I will post a video of the procedure i take, so you can tell me if I'm doing it correct.

Peter Arnold said:

Sounds a frustrating start but I have been there!

If your props started spinning immediately it could mean the ESC's need calibrating and it may play to redo the radio calibration again. For the nose dive check the motors are plugged into the PH in the correct order and spinning correctly. Redo the wizard setup is a good start. Good luck. 

if you were in alt hold gps hold etc the quad would have been trying to change throttles to match. to balance the quad (level out)

wrong prop direction or incorrectly calibrated ESC etc could all lead to your issue(s)

ptegler

My vote is ESC calibration. ...

I don't know what happened, but my reply to Paul Tegler was deleted.

I was trying to lift off in de "Stabilize" mode. I have calibrated my ESC's, but I think it has failed or something. I don't know exactly what the problem is, but ESC calibration could be a problem. When I calibrated my ESC's, the motors were responding like they should. When I raised the throttle a bit, they started to spin at low RPM and as I raised the throttle they sped up. So, I was really surprised when I tried to fly it, that it completely went wrong...
Does anyone have an explanation for the fact that the throttle was speeding up by itself?

The motor would only be doing what the throttle stick is telling them to do. Take out any expo or curve in your tx, then recalibrate your radio and also the ESC's again. This should match the throttle position to the ESC's. Calibration the ESC's can be a bit confusing especially if you do it through the pixhawk as here are so many beeps going on. If the calibration is successful the motor spin will match the throttle position. That is the last step in the esc calibration is to take the throttle to the bottom. You should get 2 beeps to say it is set. Then move the throttle up and down and the motors should all work the same. 

I had removed the expo before attempting my first flight. I did the radio calibration multiple times, as well as the ESC calibration. The RPM of the motors match the throttle stick position when I am in ESC calibration mode, so I am kind of confused..

Peter Arnold said:

The motor would only be doing what the throttle stick is telling them to do. Take out any expo or curve in your tx, then recalibrate your radio and also the ESC's again. This should match the throttle position to the ESC's. Calibration the ESC's can be a bit confusing especially if you do it through the pixhawk as here are so many beeps going on. If the calibration is successful the motor spin will match the throttle position. That is the last step in the esc calibration is to take the throttle to the bottom. You should get 2 beeps to say it is set. Then move the throttle up and down and the motors should all work the same. 

If you follow my directions, your Quad should fly the first time.

Mission Planner settings:

1. Disable GC fail safe.
2. Disable Throttle Fail Safe.

NEXT

1. When you are done doing ESC calibration, make sure you unplug USB cable and the battery. Wait 10 seconds and power up the Pixhawk through USB cable only while mission planner is still running. Allow Pixhawk to power up properly.

2. You should listen to standard Pixhawk power up beeps. If you hear a different style of beeps means Pixhawk didn't power up in standard mode and it still stuck in ESC calibration mode.

3. I am assuming you know how to install the props in proper directions etc.

4. Set your flight mode switch for Stabilize, next Loitter, next RTL.

5. Take your quad outside and wait till you have a GPS lock. means Pixhawk lights will blink Green. Still, wait another minute even when it's green.

6. Arm the Quad. Check and see if the light is still green.

7. ARM the quad through Tx and allow props to spin. Don't increase throttle. Watch and wait till you see if the PixHawk gets disarmed automatically because you didn't increase the power.

8. If above all works out fine, arm the quad again, slowly increase throttle till quad slowly lifts from the ground.

9. Immediately switch to loiter mode. Allow the quad to go up and increase throttle slightly if you need to compensate for loiter to work properly.

10. Stay in Loiter mode for few minutes. try rotating the quad, go in different directions.

11. Switch to RTL, and see if comes back.

Everything works well, land the quad.

next time try in Stabilize alone and see if you have better control this time.

Good luck. Post a video of your flight.


Also always provide details like quad type, motor types, esc types, radio type etc. etc.

Thanks for you answer iSkyMaster! I will reflash the firmware and do everything from scratch. I will follow your steps.

What parameters or things are essential for a good first flight, except for the initial calibrations like accelerometer, ESC, motors, radio etc. of course?

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service