Rover goes in tight circles when in Auto and RTL mode. Error Compass Variance Alert.

The rover works completely in manual mode, but whenever I switch to auto or RTL the rover just turns in tight circles. I get an error message "Error compass variance". I recalibrated the compass, but that did not do anything. Could I be receiving too much interference from the motor controller? Below are pictures of my build, and various mission planner windows.

Views: 1097

Replies to This Discussion

Hi,

what about Battery 0.00v 0.0A ?

Same problem. Something weird is happening. My bot worked just fine but all we do is do tight circles. Gps lock is fine. No changes made. Sucks. Wife is mad that I am upset at all the time wasted.

@Jake,

You should have always had the Sabertooth in the independent motor configuration and SKID_STEER_OUT set to 1 so that the Pixhawk would do the differential steering mixing.

Regards,

TCIII AVD

The compass variance comes from thé différent orientation between the Pixhawk and external compass. You seem to have a 180degree difference based on your pictures. You ave to set the orientation parameter right of the external compass.

@Jake,

Why do you have APM with External Compass checked if you are using a Pixhawk?

Also, I would put the 3DR telemetry radio at the rear of the Rover away from the GPS.

Regards,

TCIII AVD

First compass checked
Secondary compass checked
Third compass checked

what's wrong ?

Just disable all compasses, go outdoor and use GPS generated heading

Did you ever get this figured out? Mine is doing the exact same thing...even the variance error. My Pixhawk and Compass are directly in-line with each other. Should I raise the compass above the Pixhawk? Much like you would have setup in a standard multirotor config?

Did I mention the Sabertooth's manual drives me nuts when it states "up and down" for the switches instead of "on and off" as it's labled? I plan on changing the mixing to "indpendent" and then skid_steer_out to 1 as mentioned above.....

Hi All,

I've been fiddling with a new drone and can't seem to get this figured out either. 

I have a SaberTooth ESC and have tried mixed and independent modes with various settings and wiring configurations.    The mixed mode is much more responsive than the independent mode, or at least what I have experienced.

 I have a 4 WD chassis with a motor at each wheel.  I've tried skid steering and non skid steering.

I've managed to get the chassis moving in the right direction using the RC controller in a couple of different configurations.  But when in the auto mode only one configuration allows the chassis to move in a predicitable way, but that configuration has issues with steering at low speed. The chassis moves to the first waypoint and then stops, not sure what is going there yet, Any suggestions?

But my question is this.

Is there a reason the pixhawk has to be in the Skid Steer mode?  Can someone explain the control logic and why it is required to have the PH in skid steer mode? 

Thanks,
Tim 
 
Nathan Jones said:

Did you ever get this figured out? Mine is doing the exact same thing...even the variance error. My Pixhawk and Compass are directly in-line with each other. Should I raise the compass above the Pixhawk? Much like you would have setup in a standard multirotor config?

Did I mention the Sabertooth's manual drives me nuts when it states "up and down" for the switches instead of "on and off" as it's labled? I plan on changing the mixing to "indpendent" and then skid_steer_out to 1 as mentioned above.....

I've noticed if I let the Pixhawk do the mixing the power is decreased, especially in turns. I remember reading somewhere that it's coded to decrease power by 50% on each side for turns. I haven't found the right combination to make it drive in auto mode with the Pixhawk NOT doing the mixing..

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service