I'm trying to get a new rover up and running and keeping hitting bumps...and also my head on the wall! Please help before this beast runs me over lol!

Overview: 

-200lb custom built steel frame rover. It resembles a very small UPS truck. 

-Casters up front, 2 independent 750w rear motors

-2x60 Sabertooth controller

-Pixhawk

-Futaba RxTx system

-915mz telemetry

-5.8ghz video transmission

As for what we have tried:

-Setup as a rover in Mission Planner. 

-Right hand stick controls everything great in Manual mode.

-Have toggle skid_steer_out from 1 to 0 multiple times

-Sabertooth we have also toggled from mixed to independent mode with every combination with skid_steer_out

-Signal input wires are currently in Pixhawk channels 1 and 2. We have also tried switching these with the above two points multiple times

-GPS has 7+ sats and great hdop values. 

Outcomes in automated mode with waypoints loaded:

-Only 1 motor being powered resulting in death circles

-Rover not going to a waypoint, but off in an total different direction

-Just plain ol crazy back and forth behavior. 

With all this I'm looking for "how should it be wired/switched/configured"? I'm very familiar with multirotors and have 2 other pixhawks working fine in them.

Any advice/things to try would be much appreciated. I know we have to have a combination of the above that works, just can't crack the code! I have another sabertooth on the way just in case it has something wrong with it!

Thanks in advance!

Views: 698

Replies to This Discussion

@Nathan,

Please provide your full parameter list as a text file to assist with troubleshooting your navigation issue.

The Sabertooth Motor Controller should be configured in the independent mode.

You might try checking the "reverse" box on the roll bar in the MP radio calibration screen.

Regards,

TCIII AVD

For skid steering the motors should be connected to Output 1 and 3!

Try this. It works perfectly for me. I ran a self built rover a lot last summer with MP routes.
The Sabertooth is controlled by jumpers and does not EVER change behavior unless you got a faulty one.

My SaberTooth settings: DUDUU (D=Down=Off, U=Up=On)
Note that the switch is mounted upside/down compared to the printed text.

Regards

Anders

As for my parameter list it's a clean install over Rover without any changes right now. I wiped it clean in anticipation of getting the new sabertooth and starting over. 

Now Anders comment raised my eyebrows. Are you telling me what's listed in this manual is not correct?!! I'm attaching/uploading my current settings. 

Attachments:

@Nathan,

If memory serves me right, the Pixhawk skid steering outputs were on Servo Output pins 1 and 2, but I was using a Spektrum Satellite Receiver on the Pixhawk Spektrum input and not a Futaba receiver on the SBus input.

The RCMAP parameters can also affect the skid steering output depending on the type of receiver input in use.

I have only used the Sabertooth 2X25 so I cannot advise you on the configuration switch settings of the 2X60.

Regards,

TCIII AVD

Would any of the above impact auto mode, or just manual? It seems like in auto mode it shouldn't make a difference what the RCMAP parameters are in regards to the receiver? Shouldn't in auto the communication just be between the pixhawk-->sabertooh and nothing to do with the receiver?

The sabertooth DIP Switch wizard is the same for all Sabertooth

Hi, I'm having the same problems Nathan described.

My sabertooth is configured different: DUUDUD

In AUTO mode only 1 motor being powered resulting in death circles and Rover not going to a waypoint, but off in an total different direction.

In STEERING mode the motors run in different speeds doing circles, it does not go to a straight line.

Do you think it can be parameters configuration? Is it possible compare the parameters list with someone whose rover is moving correctly?

Thanks

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service