I have been trying to get my digital airspeed sensor to work and while doing some research I came across this post that claims that the "I2C2" port on the PX2.1 does not work:

http://discuss.ardupilot.org/t/pixhawk-2-1-with-maxbotic-i2cxl-maxs...

The proposed solution is to connect the device on I2C1 (on the GPS1 port). Has anyone else encountered this issue ?

Views: 930

Replies to This Discussion

still in Firmware 3.8.0 beta 5, I assume? and on what physical port?    also, does your current sensor work in this version?

DougB said:

I now have it working. I was under the incorrect assumption that the aispeed sensor static port was also providing barometric altitude data to the Pixhawk. But, the instructions say to set the ARSPD_BUS = 1, I can only make it work on ARSPB_BUS = 0 rather than what the instructions say. This is on a Pixhawk 2.1

Simon,

Since the Pixhawk 2.1 mini power brick only handles 30amps I hooked a Mauch 100a power module on the power input 1 for the main battery that runs the motor and I'm using the mini power brick on power input 2 for the flight battery that runs all the other electronics and everything is working fine.

My Mauch 100Amp power module plugged in port 1 was indicating Amps in the 1000's with FW 3.8.0beta5...

DougB said:

Simon,

Since the Pixhawk 2.1 mini power brick only handles 30amps I hooked a Mauch 100a power module on the power input 1 for the main battery that runs the motor and I'm using the mini power brick on power input 2 for the flight battery that runs all the other electronics and everything is working fine.

Hi there and welcome aboard, feel free to share your PH2.1 experience.

iSkyMaster said:

I purchased one recently. Let me play around with it and we can share things together.

Simon,

My Mauch is plugged into power port 1 and it gave some way off reading until I entered the calibration settings that came on the little sheet of paper that came with the sensor

Hi DougB, 

I have been trying to get my Eagle tree v3 airspeed sensor to work via the I2C2 bus as well. I have updated arduplane to 3.8.0 beta5 but I can't find ARSPD_BUS in the advanced params. I have updated mission planner to the latest release as well.  Is there anything else I might be doing wrong? 


DougB said:

Its ARSPD_BUS

Stefan,

Look in the "Full Parameter List" page


I must be missing something really basic here.


DougB said:

Stefan,

Look in the "Full Parameter List" page

It seems like it was just updating weirdly. I have the ARSPD_BUS parameter up now and have airspeed enabled and set to I2C airspeed sensor. It's wired into the I2C 2 port on the PH2.1. The sensor lights up and displays on its little LCD screen but no data comes through to mission planner. Any ideas? Did you plug into a different port than the I2C? Did you splice it into the GPS1 port as others have done? 

DougB said:

Stefan,

Look in the "Full Parameter List" page

Hello all,

Does anyone have any update on this? I am also trying to get the Eagle Tree Airspeed v3 sensor to work with my pixhawk 2.1 cube. I have tried seemingly everything in this thread with no success. On the HUD I get an airspeed of some constant value based on the numbers in the ratio and multiplier parameters. Right now my parameters are the default values and I am getting a speed readout of 144.6mph, and that value is completely unchanged by blowing on the sensor. By manipulating the values in the above listed fields I can get that number to read 0, but it still is clearly not an actual reading as the value never changes. 

Did you have to put the sensor in "third party mode" as ET says is necessary? I have not done this as I found pixhawk documentation that says it is not needed. 

Any help would be greatly appreciated

Alex  

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service